Уважаемые пользователи!
Напоминаем, что с 7 ноября 2020 года phpBB Group прекращает поддержку phpBB версии 3.2.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.2 до 31 декабря 2020 года.
С учетом этого, а также того, что версия 3.2.x больше не будет получать обновлений, за исключением связанных с проблемами безопасности
(только при их наличии и только до 7 ноября 2020 года), рекомендуется обновить конференции до версии 3.3.x.

[FAQ] Обновление phpBB 3.2.x/3.3.x to phpBB 3.2.x/3.3.x

Темы по наиболее часто задаваемым вопросам без привязки к версии phpBB. Читать в первую очередь!
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Мини [FAQ] по phpBB 3.1.x/3.2.x | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать расширения

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
Siava
Поддержка
Поддержка
Сообщения: 4718
Стаж: 16 лет 6 месяцев
Откуда: Питер
Благодарил (а): 142 раза
Поблагодарили: 602 раза

[FAQ] Обновление phpBB 3.2.x/3.3.x to phpBB 3.2.x/3.3.x

Сообщение Siava »

[FAQ] Обновление phpBB 3.2.x/3.3.x to phpBB 3.2.x/3.3.x
  • Скачать базовый установочный пакет 3.2.x или 3.3.x (они же Full Package на phpbb.com) с обновлённой версией форума.
  • Отключить конференцию, создать резервные копии базы данных и файлов форума.
  • Если вы обновляетесь с phpBB 3.2.x до 3.3.x, то перед обновлением отключите все расширения, так как среди них могут оказаться несовместимые с новой версией движка форума. Узнать о том, какие расширения несовместимы, можно у авторов этих расширений и/или на форумах поддержки phpBB Guru и phpbb.com.
  • Удалить файлы phpBB устаревшей версии, КРОМЕ:
    config.php
    папки /ext
    папки /files
    папки /images
    папки /store
    папки /styles
NB! папку со стандартным prosilver следует удалить и заменить из обновленной версии.
Если вы используете модифицированный или нестандартный стиль, то его следует обновить до последней версии.
  • Скопировать все файлы phpBB (с заменой) обновляемой версии (кроме config.php) в папку, где находится phpBB
  • Ввести в адресной строке и запустить/install/app.php/update (после имени домена и пути к форумам).
После успешного обновления необходимо удалить или переименовать папку /install.
Последний раз редактировалось Siava 31.01.2021 6:31, всего редактировалось 1 раз.
Еще одно нарушение правил и будете забанены. © Mr. Anderson
https://siava.ru/forum/ (phpbb 2.0.x, 3.1.x 3.5.x)
weedkappa
phpBB 1.0.0
Сообщения: 3
Стаж: 3 месяца
Благодарил (а): 1 раз

Re: [FAQ] Обновление phpBB 3.2.x/3.3.x to phpBB 3.2.x/3.3.x

Сообщение weedkappa »

[/quote]
Татьяна5 писал(а): 14.04.2021 22:50по ftp
как узнать данные для подключения,если это бесплатный форум от гетбб?
Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 10628
Стаж: 9 лет 11 месяцев
Благодарил (а): 185 раз
Поблагодарили: 3007 раз

Re: [FAQ] Обновление phpBB 3.2.x/3.3.x to phpBB 3.2.x/3.3.x

Сообщение Татьяна5 »

weedkappa, поддержка бесплатных форумов тут не оказывается
(У них спрашивайте, что они там как сделали)
dpfegr
phpBB 1.0.0
Сообщения: 3
Стаж: 1 месяц
Благодарил (а): 1 раз

Re: [FAQ] Обновление phpBB 3.2.x/3.3.x to phpBB 3.2.x/3.3.x

Сообщение dpfegr »

Добрый.
1) Подскажите кто может обновить phpbb с версии 3.0.14 до новой?
2) Ошибка при клике на шаге соглашения с условиями при регистрации.. поможет ли обновление? http://dpfegr.ru/forum/ucp.php?mode=reg ... 022e9803b6
Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 10628
Стаж: 9 лет 11 месяцев
Благодарил (а): 185 раз
Поблагодарили: 3007 раз

Re: [FAQ] Обновление phpBB 3.2.x/3.3.x to phpBB 3.2.x/3.3.x

Сообщение Татьяна5 »

dpfegr писал(а): 30.06.2021 21:05кто может
С подобными вопросами в Рекрутинг

По второму вопросу отдельная тема, вижу, уже создана
Аватара пользователя
Evangelion
phpBB 2.0.3
Сообщения: 387
Стаж: 9 лет 7 месяцев
Благодарил (а): 71 раз
Поблагодарили: 102 раза

Не работает функция обновления с 3.3.1 до 3.3.4

Сообщение Evangelion »

Обновлял по инструкции, при переходе на /install/app.php/update пишет что "Извините, но конференция в настоящий момент недоступна", если войти и ввести обновление то пишет так "Пожалуйста, удалите, переместите или переименуйте папку install....и т.д."
При этом всём /install/app.php открывается как надо, но при нажатии на "Обновить" открывает главную форума.
В админке:
Версия файлов 3.3.4
Версия СУБД 3.3.1
Татьяна5 писал(а): 02.12.2018 13:14 Очистить кеш, физически, весь
Из store удалить логи от установки/обновления
Проверить не затёрся ли config.php, если что - вернуть из бекапа
И после этого попробовать перейти ещё раз
Это всё результата не дало.
Удаление папки install и загрузка заново тоже результата не дало.
Аватара пользователя
Siava
Поддержка
Поддержка
Сообщения: 4718
Стаж: 16 лет 6 месяцев
Откуда: Питер
Благодарил (а): 142 раза
Поблагодарили: 602 раза

Re: Не работает функция обновления с 3.3.1 до 3.3.4

Сообщение Siava »

Evangelion, дайте угадаю.. у вас веб-сервер на nginx, который не настроен должным образом для работы с локейшеном /install/

Пример из docs

Код: Выделить всё

	# Correctly pass scripts for installer
	location /install/ {
		try_files $uri $uri/ @rewrite_installapp =404;

		# Pass the php scripts to fastcgi server specified in upstream declaration.
		location ~ \.php(/|$) {
			include fastcgi.conf;
			fastcgi_split_path_info ^(.+\.php)(/.*)$;
			fastcgi_param PATH_INFO $fastcgi_path_info;
			fastcgi_param SCRIPT_FILENAME $realpath_root$fastcgi_script_name;
			fastcgi_param DOCUMENT_ROOT $realpath_root;
			try_files $uri $uri/ /install/app.php$is_args$args =404;
			fastcgi_pass php;
		}
	}

	location @rewrite_installapp {
		rewrite ^(.*)$ /install/app.php/$1 last;
	}
Еще одно нарушение правил и будете забанены. © Mr. Anderson
https://siava.ru/forum/ (phpbb 2.0.x, 3.1.x 3.5.x)
Аватара пользователя
Evangelion
phpBB 2.0.3
Сообщения: 387
Стаж: 9 лет 7 месяцев
Благодарил (а): 71 раз
Поблагодарили: 102 раза

Re: Не работает функция обновления с 3.3.1 до 3.3.4

Сообщение Evangelion »

Siava, эт да, а как правильно настроить или как всё таки обновить можно?
Настраивал не я(
Пример из docs
Это что, куда?(
Аватара пользователя
Siava
Поддержка
Поддержка
Сообщения: 4718
Стаж: 16 лет 6 месяцев
Откуда: Питер
Благодарил (а): 142 раза
Поблагодарили: 602 раза

Re: Не работает функция обновления с 3.3.1 до 3.3.4

Сообщение Siava »

Evangelion, если покажите мне конфиг nginx (можно в ЛС), то напишу куда чего добавить.
Еще одно нарушение правил и будете забанены. © Mr. Anderson
https://siava.ru/forum/ (phpbb 2.0.x, 3.1.x 3.5.x)

Вернуться в «FAQ»