Проблема с вложениями

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
kaktys
phpBB 1.2.1
Сообщения: 26
Стаж: 19 лет 11 месяцев
Благодарил (а): 1 раз

Re: Проблема с вложениями

Сообщение kaktys »

kaktys писал(а):Заметил такую штуку - размер приаттаченного файла превышает ограничение установленное в админке :?
1.jpg
2.jpg
в действительности же фото весит 326кб
_http://s002.radikal.ru/i198/1103/c8/48314bbe570b.jpg

?? кто что может подсказать
стоит Advanced_Attach_Watermark_v_0_1_4
rxu писал(а):
kaktys писал(а):кто что может подсказать
Сотни раз уже сказано - на администраторов ограничения не действуют.
rxu, дело в том, что на пользователей тоже не действует. причем пишет под аттачем размер до 256кб, а если открыть изображение оно весить может сколько угодно, сейчас вот заметил 1,5мбайт..
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 17273
Стаж: 20 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 632 раза
Поблагодарили: 2413 раз

Re: Проблема с вложениями

Сообщение rxu »

kaktys писал(а):на пользователей тоже не действует
Как узнали?
Изображение
sweetah
phpBB 2.0.6
Сообщения: 506
Стаж: 16 лет 7 месяцев
Благодарил (а): 108 раз
Поблагодарили: 26 раз

Re: Проблема с вложениями

Сообщение sweetah »

Поддержка хостинга полтора дня бьется, ничего толком не могут сделать.


Описание проблемы: На форуме не работают вложения, аватары и админка! Chrome во всех случаях пишет "Ошибка HTTP 500 (Internal Server Error): При попытке сервера выполнить запрос возникла неожиданная ситуация."
Произведенные изменения, после которых начались неполадки: переезд на другой хостинг (VPS)
Версия phpBB: 3.0.8
Версия PHP: 5.2.6-1+lenny10
Используемая СУБД и её версия: MySQL 5.0.51a-24+lenny5

В логах много вот такого:

Код: Выделить всё

[Tue Apr 19 18:09:15 2011] [error] [client ******] client denied by server configuration: /srv/www/*******.***/public_html/styles/********/images/index.html, referer: http://*******.***/viewtopic.php?f=4&t=5&p=22

Код: Выделить всё

[Tue Apr 19 18:09:37 2011] [error] [client ******] PHP Warning: include() [<a href='function.include'>function.include</a>]: open_basedir restriction in effect. File(./../common.php) is not within the allowed path(s): (.) in /srv/www/*******.***/public_html/download/file.php on line 115, referer: http://******.***/index.php?sid=5a62d31f55484b8ec66d23bb773f38b1

Код: Выделить всё

[Tue Apr 19 18:09:37 2011] [error] [client ******] PHP Warning: include(./../common.php) [<a href='function.include'>function.include</a>]: failed to open stream: Operation not permitted in /srv/www/*******.***/public_html/download/file.php on line 115, referer: http://******.***/index.php?sid=5a62d31f55484b8ec66d23bb773f38b1

Код: Выделить всё

[Tue Apr 19 18:09:37 2011] [error] [client ******] PHP Fatal error: Call to undefined function request_var() in /srv/www/*******.***/public_html/download/file.php on line 117, referer: http://*******.***/index.php?sid=5a62d31f55484b8ec66d23bb773f38b1

Код: Выделить всё

[Tue Apr 19 19:56:32 2011] [error] [client ******] PHP Warning: include() [<a href='function.include'>function.include</a>]: Failed opening './../common.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /srv/www/*******.***/public_html/download/file.php on line 115, referer: http://********.***/index.php
Помогите, люди добрые :(

Добавлено спустя 6 минут 34 секунды:
Хостер просит посмотреть в phpinfo.php все ли требования для форума выполнены. Подскажите, какие именно?
Аватара пользователя
Mr. Anderson
phpBB Guru
phpBB Guru
Сообщения: 7522
Стаж: 22 года 6 месяцев
Откуда: СССР
Благодарил (а): 6 раз
Поблагодарили: 154 раза

Re: Проблема с вложениями

Сообщение Mr. Anderson »

sweetah
Ну начнем с того, что все ли CHMOD выставлены верно + может ли апач (или из под какого юзера у вас там php работает) читать/писать в папки/файлы, откуда его (судя по логам) "посылают"?
sweetah
phpBB 2.0.6
Сообщения: 506
Стаж: 16 лет 7 месяцев
Благодарил (а): 108 раз
Поблагодарили: 26 раз

Re: Проблема с вложениями

Сообщение sweetah »

А как понять выставлены они верно или нет? Они ж где-то 755, а где-то 644... На сервере стоит обычная связка lamp.
Вложения кстати заливаются на сервер, но скачать их нельзя.
Аватара пользователя
Mr. Anderson
phpBB Guru
phpBB Guru
Сообщения: 7522
Стаж: 22 года 6 месяцев
Откуда: СССР
Благодарил (а): 6 раз
Поблагодарили: 154 раза

Re: Проблема с вложениями

Сообщение Mr. Anderson »

sweetah писал(а):А как понять выставлены они верно или нет?
Открыть документацию, почитать, сверить выставленное на хосте с тем, что необходимо выставить. Исправить, если надо.
sweetah писал(а):На сервере стоит обычная связка lamp
Это мало что говорит о нюансах настройки и работы php. Как минимум возможны варианты mod_php, fastcgi... А уж из под каких пользователей и с какими правами все это запускается - вообще тайна за семью печатями. Это к суппорту вопрос, им виднее.
sweetah
phpBB 2.0.6
Сообщения: 506
Стаж: 16 лет 7 месяцев
Благодарил (а): 108 раз
Поблагодарили: 26 раз

Re: Проблема с вложениями

Сообщение sweetah »

Права сверил, все верно установлено.
Хорошо, подскажите пожалуйста что говорить и спрашивать у суппорта, я несколько растерян.
Аватара пользователя
Mr. Anderson
phpBB Guru
phpBB Guru
Сообщения: 7522
Стаж: 22 года 6 месяцев
Откуда: СССР
Благодарил (а): 6 раз
Поблагодарили: 154 раза

Re: Проблема с вложениями

Сообщение Mr. Anderson »

sweetah
Ваша задача сейчас узнать у суппорта под каким юзером работает apache и php и может ли этот юзер (с учетом chmod и owner нужных файлов/папок) читать/писать в нужные файлы/папки (смотрите в логах).

А вообще:
sweetah писал(а):client denied by server configuration
На 99% - неверная конфигурация VirtualHost в apache.

Добавлено спустя 3 минуты 5 секунд:
И это... Покажите содержимое директивы <Directory> из httpd.conf

PS:
Подозреваю я, что таки упячка 2.2 в дефолте... Тогда это хороший и опытный суппорт, дааа :)
sweetah
phpBB 2.0.6
Сообщения: 506
Стаж: 16 лет 7 месяцев
Благодарил (а): 108 раз
Поблагодарили: 26 раз

Re: Проблема с вложениями

Сообщение sweetah »

Про поддержку ещё с самого начала мысли нехорошие были...
Гм, в httpd.conf нет ничего, кроме

Код: Выделить всё

AddType application/x-httpd-php phtml php 
LoadModule php5_module etc/php5/php5apache2.dll
php_admin_value open_basedir none
Есть ещё apache2.conf
Аватара пользователя
Mr. Anderson
phpBB Guru
phpBB Guru
Сообщения: 7522
Стаж: 22 года 6 месяцев
Откуда: СССР
Благодарил (а): 6 раз
Поблагодарили: 154 раза

Re: Проблема с вложениями

Сообщение Mr. Anderson »

sweetah писал(а):apache2.conf
Ну а в нем есть требуемая директива? :?
Аватара пользователя
Alek$
Former team member
Сообщения: 2616
Стаж: 21 год 1 месяц
Откуда: Новосибирск
Поблагодарили: 37 раз

Re: Проблема с вложениями

Сообщение Alek$ »

sweetah
php в safe mode? Если да, то попробуйте для начала вырубить safe mode.
Самая страшная ошибка, это ошибка без видимых причин и конкретных последствий.
phpBB3 [db_update.php generator]
Первая помощь по всем phpBB-вопросам: phpBB2 и phpBB3 FAQ; Правила общения;
Все консультации в icq или личке - на платной основе.
sweetah
phpBB 2.0.6
Сообщения: 506
Стаж: 16 лет 7 месяцев
Благодарил (а): 108 раз
Поблагодарили: 26 раз

Re: Проблема с вложениями

Сообщение sweetah »

Alek$, safe mode был выключен, он не при чем.

Mr. Anderson, вобщем с помощью утилиты htop, узнал что apache выполняется от юзера www-data. У меня все файлы форума принадлежат юзеру root, видимо поэтому проблемы?
Каким образом расширить права у www-data? Или нужно добавить нового юзера и сделать его владельцем всех файлов форума?
Аватара пользователя
Mr. Anderson
phpBB Guru
phpBB Guru
Сообщения: 7522
Стаж: 22 года 6 месяцев
Откуда: СССР
Благодарил (а): 6 раз
Поблагодарили: 154 раза

Re: Проблема с вложениями

Сообщение Mr. Anderson »

sweetah
Достаточно сделать chown нужным файлам/папкам (можно chown -R user:group /path/to/dir для всех каталогов, подкаталогов и файлов по указанному пути)
Только не забудьте указать не только пользователя, но и его группу (обычно одинакова с именем юзера)
sweetah
phpBB 2.0.6
Сообщения: 506
Стаж: 16 лет 7 месяцев
Благодарил (а): 108 раз
Поблагодарили: 26 раз

Re: Проблема с вложениями

Сообщение sweetah »

Кстати, ответ от поддержки
Если php работает в fastCGI, то он должен слушать какой-то порт (обычно 9000).
Это здорово, но как узнать режим работы я так и не разобрался.
Аватара пользователя
Mr. Anderson
phpBB Guru
phpBB Guru
Сообщения: 7522
Стаж: 22 года 6 месяцев
Откуда: СССР
Благодарил (а): 6 раз
Поблагодарили: 154 раза

Re: Проблема с вложениями

Сообщение Mr. Anderson »

По правилам, чтобы не было дальнейших проблем, файлы должны принадлежать юзеру, под которым вы работаете по FTP. Иначе вы просто не сможете работать по FTP - файлы-то "чужие".
И обычно такая настройка не вызывает проблем с доступом "из-под" юзера апача. Но если проблемы есть - тогда в качестве эксперимента поставьте владельцем (про группу не забываем!) www-data

PS:
И повторю вопрос про директиву <Directory>

Добавлено спустя 44 секунды:
sweetah писал(а):Если php работает в fastCGI, то он должен слушать какой-то порт (обычно 9000).
То есть сами они не знают как настраивают VPS перед отдачей их пользователю? :?

Вернуться в «Поддержка phpBB 3.0.х»