Поисковые индексы

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
Petruxa12
phpBB 2.0.2
Сообщения: 331
Стаж: 15 лет 4 месяца
Откуда: Москва
Благодарил (а): 156 раз
Поблагодарили: 6 раз

Re: Поисковые индексы

Сообщение Petruxa12 »

подскажите!

Что мне надо в настройках поменять чтобы поиск работал правильно.

Например,у меня на форуме есть тема "Свечи"
В поиске я набираю слово "свечи"

и мне в ответ:
Следующие слова в поисковом запросе были проигнорированы, так как являются слишком употребимыми: свечи.
Для поиска вы должны ввести как минимум одно слово. Длина каждого слова должна быть не менее 2 и не более 20 символов, исключая символ шаблона *.
:idea: phpBB 3.2.7 :idea:
Shredder
Former team member
Сообщения: 2266
Стаж: 17 лет 9 месяцев
Благодарил (а): 283 раза
Поблагодарили: 584 раза

Re: Поисковые индексы

Сообщение Shredder »

Petruxa12
Порог общих слов смените.
Аватара пользователя
Petruxa12
phpBB 2.0.2
Сообщения: 331
Стаж: 15 лет 4 месяца
Откуда: Москва
Благодарил (а): 156 раз
Поблагодарили: 6 раз

Re: Поисковые индексы

Сообщение Petruxa12 »

Не понял :oops:
:idea: phpBB 3.2.7 :idea:
Shredder
Former team member
Сообщения: 2266
Стаж: 17 лет 9 месяцев
Благодарил (а): 283 раза
Поблагодарили: 584 раза

Re: Поисковые индексы

Сообщение Shredder »

Зайдите в настройки поиска в админке, там это самая нижняя опция.
Аватара пользователя
Petruxa12
phpBB 2.0.2
Сообщения: 331
Стаж: 15 лет 4 месяца
Откуда: Москва
Благодарил (а): 156 раз
Поблагодарили: 6 раз

Re: Поисковые индексы

Сообщение Petruxa12 »

у меня стоит 5%.
:idea: phpBB 3.2.7 :idea:
Shredder
Former team member
Сообщения: 2266
Стаж: 17 лет 9 месяцев
Благодарил (а): 283 раза
Поблагодарили: 584 раза

Re: Поисковые индексы

Сообщение Shredder »

Попробуйте выставить большее значение, или вообще отключить, если не нужно. Только после этого будет необходимо пересоздать поисковые индексы.
Аватара пользователя
Petruxa12
phpBB 2.0.2
Сообщения: 331
Стаж: 15 лет 4 месяца
Откуда: Москва
Благодарил (а): 156 раз
Поблагодарили: 6 раз

Re: Поисковые индексы

Сообщение Petruxa12 »

а как пересоздавать поисковые иднексы?
:idea: phpBB 3.2.7 :idea:
Shredder
Former team member
Сообщения: 2266
Стаж: 17 лет 9 месяцев
Благодарил (а): 283 раза
Поблагодарили: 584 раза

Re: Поисковые индексы

Сообщение Shredder »

Обслуживание --> Поисковые индексы.

Читайте документацию, там всё написано.
Аватара пользователя
Petruxa12
phpBB 2.0.2
Сообщения: 331
Стаж: 15 лет 4 месяца
Откуда: Москва
Благодарил (а): 156 раз
Поблагодарили: 6 раз

Re: Поисковые индексы

Сообщение Petruxa12 »

прочитал,спасибо,не подскажите не повредит ли удаление ? Думаю поставить 0%
:idea: phpBB 3.2.7 :idea:
Аватара пользователя
Пчелкин
phpBB 3.3.0
Сообщения: 11361
Стаж: 16 лет 8 месяцев
Благодарил (а): 1832 раза
Поблагодарили: 1358 раз

Re: Поисковые индексы

Сообщение Пчелкин »

после создания все станет чикипуки..
NIKON-D90, AF-S 18-105, AF-S 14-24, AF-S 24-70
Аватара пользователя
Petruxa12
phpBB 2.0.2
Сообщения: 331
Стаж: 15 лет 4 месяца
Откуда: Москва
Благодарил (а): 156 раз
Поблагодарили: 6 раз

Re: Поисковые индексы

Сообщение Petruxa12 »

а что конкретно надо удалять?
Fulltext mysql
ЗНачение 32632

Fulltext native (активен)
Общее количество индексированных слов: Значение 106749
Число слов, связанных с сообщениями: 597468
:idea: phpBB 3.2.7 :idea:
Shredder
Former team member
Сообщения: 2266
Стаж: 17 лет 9 месяцев
Благодарил (а): 283 раза
Поблагодарили: 584 раза

Re: Поисковые индексы

Сообщение Shredder »

Всё удаляй и создай заново native, раз он у тебя активен.
Аватара пользователя
Petruxa12
phpBB 2.0.2
Сообщения: 331
Стаж: 15 лет 4 месяца
Откуда: Москва
Благодарил (а): 156 раз
Поблагодарили: 6 раз

Re: Поисковые индексы

Сообщение Petruxa12 »

удалил.
Теперь такое слово "Свечи" не находит :((( или надо ждать когда он это всё проиндексирует?
:idea: phpBB 3.2.7 :idea:
Аватара пользователя
HAMMER663
Former team member
Сообщения: 2032
Стаж: 16 лет 5 месяцев
Откуда: Зеленоград
Благодарил (а): 77 раз
Поблагодарили: 249 раз

Re: Поисковые индексы

Сообщение HAMMER663 »

Ждать надо
luna1
phpBB 1.0.0
Сообщения: 6
Стаж: 14 лет 7 месяцев

Re: Поисковые индексы

Сообщение luna1 »

PostgreSQL 8.1.23 , Fulltext native (активен) при попытке удалить поисковые индексы вываливается...

Код: Выделить всё

Общая ошибка
SQL ERROR [ postgres ]

ERROR: нужно быть владельцем связи phpbb_search_wordlist []

SQL

TRUNCATE TABLE phpbb_search_wordlist

BACKTRACE

FILE: [ROOT]/includes/db/postgres.php
LINE: 211
CALL: dbal->sql_error()

FILE: [ROOT]/includes/search/fulltext_native.php
LINE: 1423
CALL: dbal_postgres->sql_query()

FILE: [ROOT]/includes/acp/acp_search.php
LINE: 302
CALL: fulltext_native->delete_index()

FILE: [ROOT]/includes/acp/acp_search.php
LINE: 46
CALL: acp_search->index()

FILE: [ROOT]/includes/functions_module.php
LINE: 507
CALL: acp_search->main()

FILE: [ROOT]/adm/index.php
LINE: 74
CALL: p_master->load_active()
При попытке Очистить кэш тоже выкидывает ошибку

Код: Выделить всё

Общая ошибка
SQL ERROR [ postgres ]

ERROR: нужно быть владельцем связи phpbb_moderator_cache []

SQL

TRUNCATE TABLE phpbb_moderator_cache

BACKTRACE

FILE: [ROOT]/includes/db/postgres.php
LINE: 211
CALL: dbal->sql_error()

FILE: [ROOT]/includes/functions_admin.php
LINE: 2351
CALL: dbal_postgres->sql_query()

FILE: [ROOT]/includes/acp/acp_main.php
LINE: 344
CALL: cache_moderators()

FILE: [ROOT]/includes/functions_module.php
LINE: 507
CALL: acp_main->main()

FILE: [ROOT]/adm/index.php
LINE: 74
CALL: p_master->load_active()
Тоесть как я думаю, меня не допускают к БД ? Нет прав или чего? Недавно по непонятным причинам у нас на хостинге "удалился" пользователь, хостер создал нового, форум заработал, но возможно нужно было где то что то прописать...дать ему права ? Верны ли мои предположения? Как можно исправить?

Вернуться в «Поддержка phpBB 3.0.х»