Проблема с массовой рассылкой писем

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
kupidon
phpBB 1.4.4
Сообщения: 120
Стаж: 14 лет 5 месяцев
Благодарил (а): 62 раза

Re: Проблема с массовой рассылкой писем

Сообщение kupidon »

Прошу прощения, но хочу вклиниться в вашу тему...
Проблема та же, та же ошибка...одному отправляет без ошибок...
Отправка всем пользователям- выдало ошибку...
Отправка группе - выдало ошибку
Отправка группе несколько раз с разными настройками (приоритет)- ошибка
Ответ хостера на запрос по ограничениям: "Да, ограничения есть. Максимальное количество писем отправляемых через наш smtp сервер — не более 100 писем в час, не более 1000 писем в день. Размер одного письма ограничен 50Мб. Письмо должно иметь не более 100 получателей (поля TO, CC, BCC)."
В настройках пакет- 20 писем. smtp не настраивал, все штатными средствами....теперь результат:
через какое то время пришли несколько писем в группу, письмо простому пользователю (мой доп аккаунт) ...

ВОПРОС: рассылка видимо прошла, но частично или нет не ясно. КАК МОЖНО УВИДЕТЬ (сделать ) ОТЧЕТ ПО РАССЫЛКЕ,КОМУ ОТПРАВЛЕНО, КОМУ НЕТ...?
Аватара пользователя
psyhosis
phpBB 1.4.2
Сообщения: 53
Стаж: 14 лет
Откуда: Томск
Благодарил (а): 1 раз
Поблагодарили: 1 раз

Re: Проблема с массовой рассылкой писем

Сообщение psyhosis »

только если логи майл-сервера поглядеть, там ВСЕ видно будет
Первая компьютерная война началась после того, как пингвин разбил яблоком окно
Аватара пользователя
kupidon
phpBB 1.4.4
Сообщения: 120
Стаж: 14 лет 5 месяцев
Благодарил (а): 62 раза

Re: Проблема с массовой рассылкой писем

Сообщение kupidon »

подскажите пожалуйста как это сделать? я в этом двоечник :( . это запрос делать почтовому провайдеру, или самому можно?
Аватара пользователя
IgorOkCJ
phpBB 1.0.0
Сообщения: 9
Стаж: 16 лет 9 месяцев
Благодарил (а): 4 раза

Re: Проблема с массовой рассылкой писем

Сообщение IgorOkCJ »

а кто может разьяснить следующую ситуацию: Выбираю 2 любых человека из списка пользователей на форуме и отправляю им массовое сообщение. Результат - письмо успешно доставлено етим двум адресатам.
Потом беру еще 2-их каких-нибудь пользователя из списка, делаю все то же самое, но в результате - ОШИБКА!!! Как такое может быть?!
У меня уже мысль пошла: может это связанно, с почтовыми серверами, которые используют эти пользователи??
Аватара пользователя
psyhosis
phpBB 1.4.2
Сообщения: 53
Стаж: 14 лет
Откуда: Томск
Благодарил (а): 1 раз
Поблагодарили: 1 раз

Re: Проблема с массовой рассылкой писем

Сообщение psyhosis »

логи самого веб-сервера вам доступны?
IgorOkCJ, а почта у этих других пользователей точно почта, или там фигня какая нибудь написана, ошибка может быть связана с проверкой условия на корректность адреса.
в логе веб-сервера ничего подозрительного нет? или более детального?
Первая компьютерная война началась после того, как пингвин разбил яблоком окно
Аватара пользователя
kupidon
phpBB 1.4.4
Сообщения: 120
Стаж: 14 лет 5 месяцев
Благодарил (а): 62 раза

Re: Проблема с массовой рассылкой писем

Сообщение kupidon »

psyhosis писал(а):логи самого веб-сервера вам доступны?
Вообще-то что-то доступно- вы мне ткните пальцем я посмотрю....если конечно они ведутся. Логи access и error точно есть -причем почему то несколько файлов одинаковых....а про почтовые не знаю
romeo_piter
phpBB 2.0.22
Сообщения: 1375
Стаж: 17 лет 5 месяцев
Благодарил (а): 260 раз
Поблагодарили: 32 раза

Re: Проблема с массовой рассылкой писем

Сообщение romeo_piter »

Проблема сохранилась. Проблема эта не на стороне хостера, а скорее проблема движка, связанная с определенной логикой заполнения полей при отправке нескольким адресатам.

Есть такой мод https://www.phpbb.com/community/viewtopic.php?t=985195 Он использует встроенную функцию отправки из админки.
Там есть скрипт проверки работоспособности.

Вот в результате проверки скрипт пишет The mail function is activated. But it not support the bcc....
Те функция отправки работает но не поддерживается какая-то BCC, из-за которой собственно и не получается отправлять группе клиентов.

Хостер от ситуации открещивается, у него ограничений нет (ВПС). Судя по отзвам с официала проблема подобная есть у большого количества людей, решения нет.
Есть ли способ или мод, отправлять письма кучей, но чтоб отправка шла по одному?
Вообще, есть какое-то решение в этой ситуации?

Добавлено спустя 23 минуты 53 секунды:
Пробовал сделать так:
Ошибка почты

Но после этого получаем везде Host unknown

Добавлено спустя 29 минут 38 секунд:
На самом деле всё ещё грустнее ))

При отправке одиночного письма приходит отлуп The original message was received at Sun, 18 Aug 2013 11:21:55 +0400 from localhost.localdomain [127.0.0.1]

----- The following addresses had permanent fatal errors ----- <***@mail.ru>

----- Transcript of session follows ----- 550 5.1.2 <***@mail.ru>... Host unknown (Name server: mxs.mail.ru.: host not found)

Причем адрес рабочий, аналогично с почтой на яндексе и т.п.
При этом письмо админу отправляется всегда без проблем. В одиночном виде или группе.
Те если отправляем письмо группе модераторы, то админу письмо доходит, а у остальной части группы undisclosed-recipients:;... List:; syntax illegal for recipient addresses
6at9
phpBB 1.4.0
Сообщения: 38
Стаж: 12 лет 4 месяца
Благодарил (а): 11 раз

Re: Проблема с массовой рассылкой писем

Сообщение 6at9 »

Приветствую. проблема схожая: пытаюсь осуществить массовую рассылку всем зарегистрированным пользователям (чуть менее тысячи), но выдает ошибку
1) логи в админке
Изображение
2) логи на хостинге
Изображение
3) собсно, 1680 строка из functions_messenger.php

Код: Выделить всё

$result = $config['email_function_name']($to, mail_encode($subject, ''), wordwrap(utf8_wordwrap($msg), 997, "\n", true), $headers);
4) может,пригодится
Изображение

Я так понял, что проблема в коде в этом куске:

Код: Выделить всё

$subject, ''
надо ли в ковычках добавить что-то?
Аватара пользователя
Kat
phpBB 1.4.0
Сообщения: 30
Стаж: 18 лет 3 месяца
Благодарил (а): 3 раза

Re: Проблема с массовой рассылкой писем

Сообщение Kat »

Кто-нибудь решил проблему массовой рассылки через "mail"?
Проблема аналогичная, такая же ошибка почты. Если одному пользователю отправлять массовую рассылку, то проходит, 2 и более, не доходит ни до одного.
На "локалке" таких проблем (с копией домена) нет, все формируется и отправляется без проблем, на машине по слабже до конца не успевает сформировать пакеты, больше половины обрабатывает, на той, что не успевает выдает ошибку, по-моему, как раз на строку 1680 из functions_messenger.php, приведенную выше. Но это на "локалке".
На реальном домене что-то по тайм-ауту вроде.
Изменение пакетов с 20 на 0 никак не повлияло, приоритет отправки не помог. Хостер говорит, что проблем не должно быть, разбивайте почту на группы, но даже двум не уходит..
Пока воспользовались smtp, отправилось. Что делать с "mail"?
Могут ли права доступа на папки и файлы повлиять на процесс отправки? На кеш уже 777 выставили, не помогло. Стандартные на папки 755, на файлы 644.

файл queue.php в кеше отсутствует.
Аватара пользователя
SeBun
phpBB 1.4.0
Сообщения: 30
Стаж: 12 лет 10 месяцев
Благодарил (а): 3 раза

Re: Проблема с массовой рассылкой писем

Сообщение SeBun »

Извиняюсь, что поднимаю прошлогоднюю тему, но так и не нашел ответа на вопрос, собственно, сабж.

Имеется форум, более 10тыс пользователей. Необходимо произвести рассылку по всем пользователям. У хостера - ограничение на количество писем. В админке настройки убогие и не позволяют в полной мере контролировать рассылку.

В идеале это должен быть мод, который периодически по крону запускает почтовый обработчик. Этот обработчик получает данные от базы, сколько писем сегодня было отправлено, в т.ч. и сообщений о регистрации, подписки и т.д., затем смотрит свою задачу, проверяет списки пользователей, которые уже получили письмо из задачи, отправляет пакет, укладываясь в ограничения хостера...

К примеру, у хостера ограничение в 1000 писем в сутки, у меня 10тыс пользователей. Я установил задачу на рассылку, мод сам 10 дней отправляет почту, рассылая по 1000 писем. Хотя в идеале это должна быть какая то очередь, т.к. потом может, допустим, зарегистрироваться человек, а админ получит бан за спам - 1001 письмо...

ИМХО, но только в таком виде я вижу нормальную массовую рассылку с сайта. Альтернатива - только платные сервисы рассылок.

Подскажите, есть ли такой мод на данный момент?
Аватара пользователя
Пчелкин
phpBB 3.3.0
Сообщения: 11361
Стаж: 16 лет 8 месяцев
Благодарил (а): 1832 раза
Поблагодарили: 1358 раз

Re: Проблема с массовой рассылкой писем

Сообщение Пчелкин »

SeBun писал(а): Подскажите, есть ли такой мод на данный момент?
Зачем?
1820.jpg
У вас нет необходимых прав для просмотра вложений в этом сообщении.
NIKON-D90, AF-S 18-105, AF-S 14-24, AF-S 24-70
Аватара пользователя
SeBun
phpBB 1.4.0
Сообщения: 30
Стаж: 12 лет 10 месяцев
Благодарил (а): 3 раза

Re: Проблема с массовой рассылкой писем

Сообщение SeBun »

Пчелкин писал(а):
SeBun писал(а): Подскажите, есть ли такой мод на данный момент?
Зачем?
И как мне, по вашему, задать ограничения на рассылку, что бы в день уходило не более 1000 писем? Те настройки, что вы показали, мне известны. У вас даже размер пакета стоит 0, то есть нет очереди. Представляете, если скрипт начнет слать более 10тыс писем? Мне бан светит однозначно при таком раскладе. Или я, как сейчас модно говорить, "не въезжаю"? В той настройке у меня стоит число 10 (размер пакета). Попытка сделать рассылку привела к бану - слишком большой поток рассылки был принят за спам и аккаунт заблокировался. Пришлось договариваться с хостером...
Аватара пользователя
Пчелкин
phpBB 3.3.0
Сообщения: 11361
Стаж: 16 лет 8 месяцев
Благодарил (а): 1832 раза
Поблагодарили: 1358 раз

Re: Проблема с массовой рассылкой писем

Сообщение Пчелкин »

Размер - 1. Приоритет - низкий..
SeBun писал(а): У вас даже размер пакета стоит 0
Дак ты сравнил мой сервак с твоим бесплатным дерьмом...
SeBun писал(а): Пришлось договариваться с хостером...
Мож лучше его кинуть на хрен?
NIKON-D90, AF-S 18-105, AF-S 14-24, AF-S 24-70
Аватара пользователя
SeBun
phpBB 1.4.0
Сообщения: 30
Стаж: 12 лет 10 месяцев
Благодарил (а): 3 раза

Re: Проблема с массовой рассылкой писем

Сообщение SeBun »

Пчелкин писал(а):Дак ты сравнил мой сервак с твоим бесплатным дерьмом...
Это платный хостинг, timeweb.ru. Работает стабильно и кидать я его не собираюсь. Вопрос был не про хостера. Есть задача - как ее решить?

Отправлено спустя 44 минуты 48 секунд:
Кстати извиняюсь за неточность, ограничения у меня следующие:
  • максимальное число писем в час, отправленных при помощи php-скрипта, - 1000;
  • максимальное число писем в день, отправленных с одного почтового ящика (через SMTP) - 2000, при этом не более 5 в секунду;
Подскажите, как мне настроить форум на единовременную рассылку писем более 10 тыс пользователям?
Аватара пользователя
Пчелкин
phpBB 3.3.0
Сообщения: 11361
Стаж: 16 лет 8 месяцев
Благодарил (а): 1832 раза
Поблагодарили: 1358 раз

Re: Проблема с массовой рассылкой писем

Сообщение Пчелкин »

SeBun писал(а): timeweb.ru.
почему то стало грустно...
Маты гнуть хостеру не пытался?
NIKON-D90, AF-S 18-105, AF-S 14-24, AF-S 24-70

Вернуться в «Поддержка phpBB 3.0.х»