Fatal error: Allowed memory size

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Om Namaha
phpBB 1.0.0
Сообщения: 4
Стаж: 15 лет 4 месяца
Благодарил (а): 1 раз

Fatal error: Allowed memory size

Сообщение Om Namaha »

Менял "Форумные права групп" для всех групп (Администраторы, Супермодераторы, Зарегистрированные пользователи и т.д.) для всех форумов.

После того как выставил все права для форума, выставил все права доступа модератора.

Весь форум работает нормально.
Только при заходе на страничку "Наша команда" выдаёт
Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 64 bytes) in /home/mysite/htdocs/forum_new/includes/db/mysql.php on line 250
В чём может быть проблема?
Аватара пользователя
FEAR93
Former team member
Сообщения: 666
Стаж: 17 лет 11 месяцев
Откуда: Кривой Рог, Украина
Благодарил (а): 22 раза
Поблагодарили: 76 раз

Re: Fatal error: Allowed memory size

Сообщение FEAR93 »

Om Namaha писал(а):В чём может быть проблема?
Попробуйте в .htaccess добавить строчку php_value memory_limit 32M
Аватара пользователя
Mr. Anderson
phpBB Guru
phpBB Guru
Сообщения: 7522
Стаж: 22 года 6 месяцев
Откуда: СССР
Благодарил (а): 6 раз
Поблагодарили: 154 раза

Re: Fatal error: Allowed memory size

Сообщение Mr. Anderson »

FEAR93
А смысл?
Om Namaha писал(а):memory size of 33554432
И есть 32М.
Аватара пользователя
FEAR93
Former team member
Сообщения: 666
Стаж: 17 лет 11 месяцев
Откуда: Кривой Рог, Украина
Благодарил (а): 22 раза
Поблагодарили: 76 раз

Re: Fatal error: Allowed memory size

Сообщение FEAR93 »

Mr. Anderson писал(а):А смысл?
Тогда нужно увеличивать значение.
Om Namaha
phpBB 1.0.0
Сообщения: 4
Стаж: 15 лет 4 месяца
Благодарил (а): 1 раз

Re: Fatal error: Allowed memory size

Сообщение Om Namaha »

Спасибо на этом. Будем пробовать.
Vitos
phpBB 1.0.0
Сообщения: 1
Стаж: 15 лет 4 месяца
Благодарил (а): 1 раз

Re: Fatal error: Allowed memory size

Сообщение Vitos »

FEAR93 писал(а):
Mr. Anderson писал(а):А смысл?
Тогда нужно увеличивать значение.
Подскажи пожалуйста - где именно менять надо?! в каком файле и тд.
Аватара пользователя
FEAR93
Former team member
Сообщения: 666
Стаж: 17 лет 11 месяцев
Откуда: Кривой Рог, Украина
Благодарил (а): 22 раза
Поблагодарили: 76 раз

Re: Fatal error: Allowed memory size

Сообщение FEAR93 »

Vitos писал(а):в каком файле и тд.
Файл .htaccess в корне форума.
Аватара пользователя
Slash
phpBB 2.0.10
Сообщения: 794
Стаж: 15 лет 7 месяцев
Благодарил (а): 101 раз
Поблагодарили: 79 раз

Re: Fatal error: Allowed memory size

Сообщение Slash »

В поисках подходящего хостинга... В общем переехал на другой хостинг и эррол_лог пишет:

Код: Выделить всё

[10-May-2013 19:41:13 Europe/Moscow] PHP Fatal error: Allowed memory size of 201326592 bytes exhausted (tried to allocate 1853187651 bytes) in /home/bh49858/public_html/common.php on line 19
хостер посоветовал в .htaccess прописать:

Код: Выделить всё

php_value memory_limit 256M
я прописал... Сегодня проверяю, а там опять:

Код: Выделить всё

Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 1853187651 bytes) in /home/bh49858/public_html/common.php on line 19
и вот такое появляется:

Код: Выделить всё

[10-May-2013 22:01:50 Europe/Moscow] PHP Warning: require(phpbb_includes/acm/acm_file.php) [<a href='function.require'>function.require</a>]: failed to open stream: No such file or directory in /home/bh49858/public_html/style.php on line 47
[10-May-2013 22:01:50 Europe/Moscow] PHP Fatal error: require() [<a href='function.require'>function.require</a>]: Failed opening required 'phpbb_includes/acm/acm_file.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/bh49858/public_html/style.php on line 47
хотя все файлы на месте были всегда. Об этом написал хостеру, пока ответа нет....

Где то читал, что на php 5.3.3 не срабатывает: php_value memory_limit

Пробовал прописать себе в index.php после <php так ini_set('memory_limit', '256M');, но ошибка все ровно появляется...
Даже ума не приложу, что может нагружать больше чем 200 мегабайт...

Вот строка 19:

Код: Выделить всё

require($phpbb_root_path . 'includes/startup.' . $phpEx); 
Аватара пользователя
MIT
Former team member
Сообщения: 2500
Стаж: 17 лет 6 месяцев
Откуда: 56°20′02″ с. ш. 36°42′45″ в. д.
Благодарил (а): 3 раза
Поблагодарили: 351 раз

Re: Fatal error: Allowed memory size

Сообщение MIT »

Raisin писал(а):Где то читал, что на php 5.3.3 не срабатывает: php_value memory_limit
С чего бы вдруг ему не срабатывать? Более того, не видишь что ли, что в ошибке уже фигурирует именно превышение ограничения в 256 метров, вместо ~190 в изначальной?

Проверь, все ли файлы на месте, почисть кеш. Если никаких модов не ставил — пиши хостеру, ибо НЁХ творится у тебя какая-то.
Аватара пользователя
Slash
phpBB 2.0.10
Сообщения: 794
Стаж: 15 лет 7 месяцев
Благодарил (а): 101 раз
Поблагодарили: 79 раз

Re: Fatal error: Allowed memory size

Сообщение Slash »

MIT писал(а):Проверь, все ли файлы на месте
Проверял - все на своих местах...
MIT писал(а):Если никаких модов не ставил
Моды стоят:
Adaptive Hide BBcodes, Advanced Similar Topics, Advertisement Management, Buttons menu MOD, First post on every page for phpBB3, Google поиск по сайту, HighSlide 4.1.8 Attachment MOD, IP пользователя в мини профиле, Last post topic on index for phpBB3, Length of service for phpBB3, List subforums in columns (Список подфорумов в столбик), Manage attachments module for phpBB3, Mods Database, NV Newspage, NV Recent Topics, phpBB SEO Dynamic Meta Tags, Polls on index, Post number in viewtopic, Posts merging - Склеивание сообщений / постов, Prime Links, Quick Reply phpBB 3.0.6, Quote Post Back Link (QPBL), Referrals FX, Simple Url To Link Name before posting, Sitemap FX, th23 Error Pages, User Reputation Points, Спасибо за сообщение (система рейтинга), Поиск по разделу на главной странице, Парсер сообщений (автозамена), Кто был на конференции сегодня, Запрет редактирования если сообщение не последнее в теме, Выпадающая форма входа (Dropdown login box).

Версия форума: 3.0.11
Ошибки появились, после переезда на другой хостинг.... Сам хостер утверждает, что на его стороне все нормально, что дело в скриптах...

Не пойму, что так нагружает сервер? И проверить не могу...
Аватара пользователя
Пчелкин
phpBB 3.3.0
Сообщения: 11361
Стаж: 16 лет 8 месяцев
Благодарил (а): 1832 раза
Поблагодарили: 1358 раз

Re: Fatal error: Allowed memory size

Сообщение Пчелкин »

Все моды, что имеют опцию вырубания - вырубай...смотри что будет...Если нагрузка на оперу уменьшится - врубай по одному и смотри какой мод заортачился... На одном форуме два месяца бились с гегом оперы...форум тормозил по жуткому ...до 504......Вычислили что сервер ложит спасибка...пришлось убирать совсем...
NIKON-D90, AF-S 18-105, AF-S 14-24, AF-S 24-70
Аватара пользователя
Slash
phpBB 2.0.10
Сообщения: 794
Стаж: 15 лет 7 месяцев
Благодарил (а): 101 раз
Поблагодарили: 79 раз

Re: Fatal error: Allowed memory size

Сообщение Slash »

Пчелкин, спасибо! [/off] Пробовал такой вариант, а те что не отключаются, удалял полностью и ставил назад - во время этого процесса ошибки не было вообще, возможно все они вмести, дружно и дали такой груз... Вчера заменил: php_value memory_limit 256M на php_value memory_limit 2048M и пока еррор_лог молчит. тфу, тфу, тфу, тук, тук, тук (постучал по дереву).
Аватара пользователя
Пчелкин
phpBB 3.3.0
Сообщения: 11361
Стаж: 16 лет 8 месяцев
Благодарил (а): 1832 раза
Поблагодарили: 1358 раз

Re: Fatal error: Allowed memory size

Сообщение Пчелкин »

Raisin писал(а):php_value memory_limit 2048M
Стоп! А всего скока на сервере? Если это ВСЯ - -уменьши...всю серверскую в php_value прописывать нельзя...
NIKON-D90, AF-S 18-105, AF-S 14-24, AF-S 24-70
Аватара пользователя
Slash
phpBB 2.0.10
Сообщения: 794
Стаж: 15 лет 7 месяцев
Благодарил (а): 101 раз
Поблагодарили: 79 раз

Re: Fatal error: Allowed memory size

Сообщение Slash »

Хостер говорит вся память равна 32 GB. Так что еще есть куда подымать, но думаю делать этого не придется.
Аватара пользователя
MIT
Former team member
Сообщения: 2500
Стаж: 17 лет 6 месяцев
Откуда: 56°20′02″ с. ш. 36°42′45″ в. д.
Благодарил (а): 3 раза
Поблагодарили: 351 раз

Re: Fatal error: Allowed memory size

Сообщение MIT »

Два гига для phpBB3? Да вы прикалываетесь...

Вернуться в «Поддержка phpBB 3.0.х»