Fatal error: Allowed memory size

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
Balamut
Former team member
Сообщения: 2214
Стаж: 21 год 6 месяцев
Откуда: {postrow.POSTER_FROM}
Поблагодарили: 146 раз

Re: Fatal error: Allowed memory size

Сообщение Balamut »

32 гига на сервер для phpBB? Да вы прикалываетесь =)
//
// That's all, Folks!
// -------------------------------------------------
Аватара пользователя
Slash
phpBB 2.0.10
Сообщения: 794
Стаж: 15 лет 7 месяцев
Благодарил (а): 101 раз
Поблагодарили: 79 раз

Re: Fatal error: Allowed memory size

Сообщение Slash »

MIT писал(а):Два гига для phpBB3? Да вы прикалываетесь...
Вовсе не прикалываюсь, была ошибка:

Код: Выделить всё

[10-May-2013 19:41:13 Europe/Moscow] PHP Fatal error: Allowed memory size of 201326592 bytes exhausted (tried to allocate 1853187651 bytes) in /home/bh49858/public_html/common.php on line 19
ставил: php_value memory_limit 256M - оказалось мало...
Ума не прилажу из-за чего такие требования. Возможно ли это из-за соседей по серверу? Ошибка появлялась не постоянно, в сутки 2-3 раза в еррор_лог...
Аватара пользователя
Balamut
Former team member
Сообщения: 2214
Стаж: 21 год 6 месяцев
Откуда: {postrow.POSTER_FROM}
Поблагодарили: 146 раз

Re: Fatal error: Allowed memory size

Сообщение Balamut »

А, ну если есть соседи, тогда, скорее всего, из-за них.
А вообще, удивительный хостер, который при наличии соседей разрешает использовать php_value memory_limit
//
// That's all, Folks!
// -------------------------------------------------
Аватара пользователя
Slash
phpBB 2.0.10
Сообщения: 794
Стаж: 15 лет 7 месяцев
Благодарил (а): 101 раз
Поблагодарили: 79 раз

Re: Fatal error: Allowed memory size

Сообщение Slash »

Smayliks писал(а):А вообще, удивительный хостер, который при наличии соседей разрешает использовать php_value memory_limit
Это мне поддержка хостинга посоветовала так сделать...
Аватара пользователя
MIT
Former team member
Сообщения: 2500
Стаж: 17 лет 6 месяцев
Откуда: 56°20′02″ с. ш. 36°42′45″ в. д.
Благодарил (а): 3 раза
Поблагодарили: 351 раз

Re: Fatal error: Allowed memory size

Сообщение MIT »

Raisin писал(а):была ошибка
Я видел.
Raisin писал(а):Возможно ли это из-за соседей по серверу?
Только если они научились телепатически заставлять твой форум потреблять более чем в 20 раз больше оперативной памяти, чем необходимо.
Smayliks писал(а):А, ну если есть соседи, тогда, скорее всего, из-за них.
Нет. Из-за соседей может (теоретически, но никак не практически) не распределиться выделенные 32 мегабайта, но никакие соседи никакими известными науке методами не способны увеличить потребление памяти твоим скриптом.
Аватара пользователя
Slash
phpBB 2.0.10
Сообщения: 794
Стаж: 15 лет 7 месяцев
Благодарил (а): 101 раз
Поблагодарили: 79 раз

Re: Fatal error: Allowed memory size

Сообщение Slash »

Блин, значит, что то с моим форумом не то.... MIT, А как можно проверить, что конкретно так нагружает (какой скрипт), если во время ошибки, на странице только сообщение о нехватке памяти, и естественно нет кнопки Explain?
После каких изменений это началось (или было) сказать не могу.
Аватара пользователя
MIT
Former team member
Сообщения: 2500
Стаж: 17 лет 6 месяцев
Откуда: 56°20′02″ с. ш. 36°42′45″ в. д.
Благодарил (а): 3 раза
Поблагодарили: 351 раз

Re: Fatal error: Allowed memory size

Сообщение MIT »

У PHP нет нормальных методов отладки, поэтому проверить можно только мозгом.
Во-первых, надо вспомнить, какие из изменений кода форума могут вызывать большое потребление памяти?
Обычно, это обработка изображений, обработка больших выборок из базы данных, особо черезжопинские методы обработки файлов (чтение, анализ) и т.п.
Во-вторых надо найти эти потенциально узкие места и поочерёдно отключать их. Если после отключения какой-то фигни всё заработает, значит проблема в этой фигне и её надо либо переделывать, либо ссылать в топку.
Аватара пользователя
Balamut
Former team member
Сообщения: 2214
Стаж: 21 год 6 месяцев
Откуда: {postrow.POSTER_FROM}
Поблагодарили: 146 раз

Re: Fatal error: Allowed memory size

Сообщение Balamut »

MIT писал(а):Нет.
Сорри, я не обратил внимание на потребление, а имел ввиду физическую нехватку оперативки.
Конечно, соседи увеличить потребление этого форума не могут.
MIT писал(а):выделенные 32 мегабайта
80486DX2-66/32/120/1 VGA =)))
//
// That's all, Folks!
// -------------------------------------------------
Аватара пользователя
c61
phpBB 2.0.6
Сообщения: 506
Стаж: 13 лет 9 месяцев
Благодарил (а): 42 раза
Поблагодарили: 251 раз

Re: Fatal error: Allowed memory size

Сообщение c61 »

Код: Выделить всё

php_value memory_limit "-1"
...и пусть соседям будет хорошо))

Raisin, если же серьёзно, то что-то многовато Queries по информации дебага. На простейших страницах за 30 зашкаливает.
Аватара пользователя
Пчелкин
phpBB 3.3.0
Сообщения: 11361
Стаж: 16 лет 8 месяцев
Благодарил (а): 1832 раза
Поблагодарили: 1358 раз

Re: Fatal error: Allowed memory size

Сообщение Пчелкин »

Smayliks писал(а):при наличии соседей разрешает использовать php_value memory_limit
И я о том же...А воще - виртуалки - г****...
NIKON-D90, AF-S 18-105, AF-S 14-24, AF-S 24-70
Аватара пользователя
Slash
phpBB 2.0.10
Сообщения: 794
Стаж: 15 лет 7 месяцев
Благодарил (а): 101 раз
Поблагодарили: 79 раз

Re: Fatal error: Allowed memory size

Сообщение Slash »

c61 писал(а):страницах за 30 зашкаливает
В темах у меня до 110 доходит, пример одной темы:

Код: Выделить всё

Time : 0.143s | 83 Queries | GZIP : On | Memory Usage: 8.57 МБ
Вчера убрал php_value memory_limit вообще, еррор_лог сразу сообщил о нехватки памяти, и как всегда не понял, что могло нагрузить... Но это была последняя ошибка до этого момента, пока больше не появлялась... (тфу, тфу, тфу, и по дереву три раза...)

Добавлено спустя 12 минут 19 секунд:
Ну вот блин, сглазил...
На главной странице: пустая и сообщение:

Код: Выделить всё

Fatal error: Allowed memory size of 201326592 bytes exhausted (tried to allocate 1853187651 bytes) in /home/bh49858/public_html/common.php on line 19
Пойду что нибудь выпью от сглаза....
Аватара пользователя
Пчелкин
phpBB 3.3.0
Сообщения: 11361
Стаж: 16 лет 8 месяцев
Благодарил (а): 1832 раза
Поблагодарили: 1358 раз

Re: Fatal error: Allowed memory size

Сообщение Пчелкин »

Напиши в пределах 512 и хватит за глаза...
Ну, не 2 гега, ОДНОЗНАЧНО...а то у тебя на БД в оперативе ничего не останется...Да там еще и на апач надо и на Имагес и прочее...
NIKON-D90, AF-S 18-105, AF-S 14-24, AF-S 24-70
Аватара пользователя
Slash
phpBB 2.0.10
Сообщения: 794
Стаж: 15 лет 7 месяцев
Благодарил (а): 101 раз
Поблагодарили: 79 раз

Re: Fatal error: Allowed memory size

Сообщение Slash »

512 тоже мало и гиг мало... Хочу разобраться из-за чего такой напряг. Ведь раньше работало без всяких лимитных дописей...
Аватара пользователя
Пчелкин
phpBB 3.3.0
Сообщения: 11361
Стаж: 16 лет 8 месяцев
Благодарил (а): 1832 раза
Поблагодарили: 1358 раз

Re: Fatal error: Allowed memory size

Сообщение Пчелкин »

Сдается мне что у тебя просто элементарное ограничение прет от хостера...тока завуалированное под исполнение скриптами форума...Так они многие делают перед разводами на переезды на более мощные серваки...
NIKON-D90, AF-S 18-105, AF-S 14-24, AF-S 24-70
Аватара пользователя
Slash
phpBB 2.0.10
Сообщения: 794
Стаж: 15 лет 7 месяцев
Благодарил (а): 101 раз
Поблагодарили: 79 раз

Re: Fatal error: Allowed memory size

Сообщение Slash »

Я спрашивал у них если я переду на другой тариф (дороже который, VIP или что то еще), они ответили, смысла переезжать нету, ошибка будет все ровно. Ну как то так...

Вернуться в «Поддержка phpBB 3.0.х»