Ошибка 500 после очистки кеша

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
Mr. Anderson
phpBB Guru
phpBB Guru
Сообщения: 7522
Стаж: 22 года 6 месяцев
Откуда: СССР
Благодарил (а): 6 раз
Поблагодарили: 154 раза

Re: Ошибка 500 после очистки кеша

Сообщение Mr. Anderson »

keke писал(а): сможете подсказать
STK и выкорчевать тапок к черту.

Потом обновиться как минимум на 3.1.9 (а лучше 3.1.10 + патч) и, если уж без тапка не живется, попробовать поставить тапок еще раз.
Аватара пользователя
keke
phpBB 1.4.1
Сообщения: 47
Стаж: 12 лет 11 месяцев
Откуда: Москва
Благодарил (а): 29 раз

Re: Ошибка 500 после очистки кеша

Сообщение keke »

Mr. Anderson писал(а): STK и выкорчевать тапок к черту.
Спасибо, попробовал с STK, ругается на тапок и он:

Код: Выделить всё

Fatal error: Call to undefined method classTTConnection::calcSwitchOptions() in /www/forumnew/ext/tapatalk/tapatalk/event/main_listener.php on line 225
Error 1: Call to undefined method classTTConnection::calcSwitchOptions() at file /www/forumnew/ext/tapatalk/tapatalk/event/main_listener.php line 225
Описал проблему в теме stk:
Re: [dev] STK for phpBB 3.1.x
Надеюсь помогут разобраться как дальше быть.
Аватара пользователя
LavIgor
Former team member
Сообщения: 3468
Стаж: 12 лет 4 месяца
Благодарил (а): 41 раз
Поблагодарили: 935 раз

Re: Ошибка 500 после очистки кеша

Сообщение LavIgor »

keke, а вот этот простенький скрипт заработает?
Если нет, удалите файлы расширения Tapatalk, очистите кэш конференции и попробуйте снова.
Аватара пользователя
keke
phpBB 1.4.1
Сообщения: 47
Стаж: 12 лет 11 месяцев
Откуда: Москва
Благодарил (а): 29 раз

Re: Ошибка 500 после очистки кеша

Сообщение keke »

LavIgor, спасибо за совет, попробую.
LavIgor писал(а): Если нет, удалите файлы расширения Tapatalk, очистите кэш конференции и попробуйте снова.
А что именно удалить, все файлы которые шли в архиве Tapatalk'а или только какие-то конкретные?

Отправлено спустя 12 минут 52 секунды:
LavIgor писал(а): а вот этот простенький скрипт заработает?
Попробовал, как я понял его запускать так site/forumfolder/frp верно?
Если да то попробовал, тоже белая страница с ошибкой:

Код: Выделить всё

Error 1: Call to undefined method classTTConnection::calcSwitchOptions() at file /www/forumnew/ext/tapatalk/tapatalk/event/main_listener.php line 225
Аватара пользователя
LavIgor
Former team member
Сообщения: 3468
Стаж: 12 лет 4 месяца
Благодарил (а): 41 раз
Поблагодарили: 935 раз

Re: Ошибка 500 после очистки кеша

Сообщение LavIgor »

keke писал(а): А что именно удалить, все файлы которые шли в архиве Tapatalk'а или только какие-то конкретные?
Да, все файлы этого расширения.

P.S. Не забываем по бэкапы на всякий случай.
Аватара пользователя
keke
phpBB 1.4.1
Сообщения: 47
Стаж: 12 лет 11 месяцев
Откуда: Москва
Благодарил (а): 29 раз

Re: Ошибка 500 после очистки кеша

Сообщение keke »

LavIgor, спасибо, попробую руками после бэкапа все почистить.

Отправлено спустя 12 минут 23 секунды:
Удалил файлы тапаталка, но это тоже не помогло, ошибка теперь такая:

Код: Выделить всё

[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/class_loader.php on line 160: require(./ext/tapatalk/tapatalk/event/main_listener.php): failed to open stream: No such file or directory
Аватара пользователя
Mr. Anderson
phpBB Guru
phpBB Guru
Сообщения: 7522
Стаж: 22 года 6 месяцев
Откуда: СССР
Благодарил (а): 6 раз
Поблагодарили: 154 раза

Re: Ошибка 500 после очистки кеша

Сообщение Mr. Anderson »

LavIgor писал(а): удалите файлы расширения Tapatalk
Эм... Зачем? Еще хуже будет...
Аватара пользователя
keke
phpBB 1.4.1
Сообщения: 47
Стаж: 12 лет 11 месяцев
Откуда: Москва
Благодарил (а): 29 раз

Re: Ошибка 500 после очистки кеша

Сообщение keke »

Mr. Anderson писал(а): Еще хуже будет...
Пока не ясно что хуже, но лучше точно не стало :(

Отправлено спустя 8 минут 35 секунд:
Mr. Anderson, подскажите пожалуйста, в случае если не помог STK какие еще есть варианты?
Аватара пользователя
Mr. Anderson
phpBB Guru
phpBB Guru
Сообщения: 7522
Стаж: 22 года 6 месяцев
Откуда: СССР
Благодарил (а): 6 раз
Поблагодарили: 154 раза

Re: Ошибка 500 после очистки кеша

Сообщение Mr. Anderson »

keke, такого быть не должно в случае с STK. Вы кеш чистили?
Аватара пользователя
keke
phpBB 1.4.1
Сообщения: 47
Стаж: 12 лет 11 месяцев
Откуда: Москва
Благодарил (а): 29 раз

Re: Ошибка 500 после очистки кеша

Сообщение keke »

Mr. Anderson писал(а): Вы кеш чистили?
Кеш в браузере чистил.
Аватара пользователя
Mr. Anderson
phpBB Guru
phpBB Guru
Сообщения: 7522
Стаж: 22 года 6 месяцев
Откуда: СССР
Благодарил (а): 6 раз
Поблагодарили: 154 раза

Re: Ошибка 500 после очистки кеша

Сообщение Mr. Anderson »

keke писал(а): Кеш в браузере
При чем тут браузерный. Кеш ФОРУМА.
Аватара пользователя
keke
phpBB 1.4.1
Сообщения: 47
Стаж: 12 лет 11 месяцев
Откуда: Москва
Благодарил (а): 29 раз

Re: Ошибка 500 после очистки кеша

Сообщение keke »

Mr. Anderson писал(а): Кеш ФОРУМА.
Вас понял, спасибо, перепроверю через фтп.
Я его точно очищал через панель администрирования, когда она еще была доступна и посчитал что раз очистил - значит там пусто.
Аватара пользователя
LavIgor
Former team member
Сообщения: 3468
Стаж: 12 лет 4 месяца
Благодарил (а): 41 раз
Поблагодарили: 935 раз

Re: Ошибка 500 после очистки кеша

Сообщение LavIgor »

Вопрос:
Mr. Anderson писал(а): Эм... Зачем? Еще хуже будет...
Ответ:
Mr. Anderson писал(а): такого быть не должно в случае с STK.
;)

Отправлено спустя 1 минуту 10 секунд:
А через FRP или STK уже вычистить остатки неотключённого расширения.
Аватара пользователя
keke
phpBB 1.4.1
Сообщения: 47
Стаж: 12 лет 11 месяцев
Откуда: Москва
Благодарил (а): 29 раз

Re: Ошибка 500 после очистки кеша

Сообщение keke »

LavIgor, Mr. Anderson, спасибо вам за помощь!

Вернуться в «Поддержка phpBB 3.0.х»