Хостер обвиняет в нагрузке на сервер.

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
staiki
phpBB 2.0.2
Сообщения: 318
Стаж: 14 лет 3 месяца
Откуда: Киев Украина
Благодарил (а): 76 раз
Поблагодарили: 9 раз
Забанен: Бессрочно

Хостер обвиняет в нагрузке на сервер.

Сообщение staiki »

Всем доброго времени суток.Вчера у меня на хосте был какой-то сбой(час сайт не был доступен).После восстановления работы (утром) в течении дня были постоянные недоступность сайта.Написал хостеру и вот что он мне пишет:
Скрытый текст
Мы проверили работу Вашей услуги.
Нами было замечено, что за последние сутки скриптами Вашего сайта были достигнуты лимиты по входным процессам (количеству одновременно запущенных PHP и CGI скриптов, заданий по расписанию и консольных сессий).

Также Вашими скриптами создается немалая нагрузка на процессор и оперативную память, что приводит к достижению пределов по использованию процессора, потреблению физической памяти и использованию ввода-вывода.Вам необходимо пересмотреть логику работы Ваших скриптов и провести необходимые работы по их оптимизации. Рекомендуем Вам обратиться к профессиональным web-разработчикам. Пожалуйста, изучите ошибки в файлах error_log, и Журнал ошибок в cpanel обычно данные ошибки могут приводить к некорректной работе скриптов и большой нагрузке на ресурсы услуги. Обновите движки ЦМС, плагины, при возможности замените тяжелые плагины более эффективными.
После этого ответа попросил конкретно отписать в чём ошибки и в каких скриптах(в логах на сайте ошибок нет)-вот что ответили:
Скрытый текст
Ошибки не обязательно логируются в журнале ЦМС. Данная проблема возникает из-за зависания скриптов, тяжелых плагинов, большой нагрузки, и.т.д.
Ошибки также наблюдались и ранее и приводили к остановкам работы сайта, можете просмотреть статистику по нагрузке в журнале за последние 30 дней.

Если запустить отладчик в браузере, клик правой кнопкой и исследовать элемент, видно много нарушений в работе, которые также могут приводить к чрезмерной нагрузке и зависанию скриптов.

Применение getUserData() или setUserData() является устаревшим. Для их замены используйте WeakMap или element.dataset. requestNotifier.js:63
Неизвестное свойство «-moz-box-shadow». Потерянное объявление. style.php:850
Неизвестное свойство «-moz-border-radius». Потерянное объявление. style.php:1186
Неизвестное свойство «-moz-box-shadow». Потерянное объявление. style.php:1189
Неизвестное свойство «voice-family». Потерянное объявление. style.php:3287
Неизвестное свойство «voice-family». Потерянное объявление. style.php:3288
Неизвестное свойство «zoom». Потерянное объявление. style.php:3373
Ожидалось объявление, но найдено «*». Пропущено до следующего объявления. style.php:3378
Неизвестное свойство «zoom». Потерянное объявление. style.php:4577
Ожидалось объявление, но найдено «*». Пропущено до следующего объявления. style.php:4578
Неизвестное свойство «zoom». Потерянное объявление. style.php:4923
Ожидалось объявление, но найдено «*». Пропущено до следующего объявления. style.php:4924
ReferenceError: end_ is not defined staiki.net:1652
Ожидались «:» или «)» после имени медиа-функции, но найдено «=». staiki.net:1
Неизвестный псевдокласс или псевдоэлемент «-o-prefocus». Набор правил проигнорирован из-за плохого селектора. staiki.net:1
Неизвестное свойство «-moz-box-shadow». Потерянное объявление. staiki.net:1
Неизвестное свойство «-moz-border-radius». Потерянное объявление. staiki.net:1
Применение getUserData() или setUserData() является устаревшим. Для их замены используйте WeakMap или element.dataset. requestNotifier.js:63
Ожидалось объявление, но найдено «*». Пропущено до следующего объявления. www-embed-player-2x-vfluObAZ0.css:1
Ожидалось «none» или «URL», но найдено «alpha(». Ошибка при парсинге значения «filter». Потерянное объявление. www-embed-player-2x-vfluObAZ0.css:1
Неизвестное свойство «-moz-border-radius». Потерянное объявление. www-embed-player-2x-vfluObAZ0.css:1
Неизвестное свойство «-moz-border-radius-topleft». Потерянное объявление. www-embed-player-2x-vfluObAZ0.css:1
Неизвестное свойство «-moz-border-radius-bottomleft». Потерянное объявление. www-embed-player-2x-vfluObAZ0.css:1
Неизвестное свойство «-moz-border-radius-topright». Потерянное объявление. www-embed-player-2x-vfluObAZ0.css:1
Неизвестное свойство «-moz-border-radius-bottomright». Потерянное объявление. www-embed-player-2x-vfluObAZ0.css:1
Ошибка при парсинге значения «cursor». Потерянное объявление. www-embed-player-2x-vfluObAZ0.css:1
Ошибка при парсинге значения «background-image». Потерянное объявление. www-embed-player-2x-vfluObAZ0.css:1
Ожидалось «none» или «URL», но найдено «progid». Ошибка при парсинге значения «filter». Потерянное объявление. www-embed-player-2x-vfluObAZ0.css:1
Неизвестное свойство «-moz-background-size». Потерянное объявление. www-embed-player-2x-vfluObAZ0.css:1
Неизвестный псевдокласс или псевдоэлемент «-webkit-scrollbar-track». Набор правил проигнорирован из-за плохого селектора. www-embed-player-2x-vfluObAZ0.css:1
Неизвестный псевдокласс или псевдоэлемент «-webkit-scrollbar». Набор правил проигнорирован из-за плохого селектора. www-embed-player-2x-vfluObAZ0.css:1
Неизвестный псевдокласс или псевдоэлемент «-webkit-scrollbar-thumb». Набор правил проигнорирован из-за плохого селектора. www-embed-player-2x-vfluObAZ0.css:1
Ошибка при парсинге значения «-moz-transition». Потерянное объявление. www-embed-player-2x-vfluObAZ0.css:1
Ошибка при парсинге значения «transition». Потерянное объявление.

Мы не являемся разработчиками Вашего сайта, к сожалению, затрудняемся Вам помочь в плане оптимизации его работы, рекомендуем обратиться к разработчикам по данному вопросу.
Ничего на сайте уже больше двух месяцев не делал.Пару недель обвиняли в вирусах на сайте во вложениях(до 50 вирусов в сутки было) при том что никто вложения у меня не заливает(кроме торрент-файлов) а теперь вот такая нарисовалась проблема.

Что скажете?
http://staiki.net/index.php Форум Компьютерная Помощь
Anvar
Former team member
Сообщения: 1964
Стаж: 16 лет 5 месяцев
Благодарил (а): 67 раз
Поблагодарили: 800 раз

Re: Хостер обвиняет в нагрузке на сервер.

Сообщение Anvar »

Файрбаг, валидатор и редактор. Если html бардак прощает, то скрипты нет.
Трекер сам по себе нагрузку дает не хилую, а тут еще код не хороший.

Хостер был бы плохой, не держал, написал бы прямо или зажал бы каналы и сам бы потом съехал, а тут рекомендации дает.
Не пишите вопросы лично, если можете задать их на форуме!
Спецзаказы не интересуют!
Аватара пользователя
Пчелкин
phpBB 3.3.0
Сообщения: 11362
Стаж: 16 лет 8 месяцев
Благодарил (а): 1832 раза
Поблагодарили: 1358 раз

Re: Хостер обвиняет в нагрузке на сервер.

Сообщение Пчелкин »

staiki писал(а):Ничего на сайте уже больше двух месяцев не делал.
А и не надо ничего делать... Просто надо было дождаться когда сервак просто задолбается все это безрассудное напихивание переваривать...
Вот и настал рубикон
PHP не прощает "пальцевеерство " и наплевательство...
Как вариант - садиться на Денвер и спокойно и скурпулезно править все ошибки в верстке...
Файербаг в помощь и валидатор... Исправить можно все... Спокойно и постепенно...

Можно еще обратиться к пагеспееду за помощью...Он очень дельные советы дает...

Добавлено спустя 1 минуту 10 секунд:
staiki писал(а): «-moz-box-shadow»
На мозы можно внимания не обращать...
NIKON-D90, AF-S 18-105, AF-S 14-24, AF-S 24-70
Аватара пользователя
***Blaze***
phpBB 2.0.7
Сообщения: 583
Стаж: 19 лет 8 месяцев
Откуда: Данков
Благодарил (а): 57 раз
Поблагодарили: 25 раз

Re: Хостер обвиняет в нагрузке на сервер.

Сообщение ***Blaze*** »

Хостинг случайно не Timeweb?
Мой сайт http://ublaze.ru/
Shredder
Former team member
Сообщения: 2266
Стаж: 17 лет 9 месяцев
Благодарил (а): 283 раза
Поблагодарили: 584 раза

Re: Хостер обвиняет в нагрузке на сервер.

Сообщение Shredder »

***Blaze***
Нет.
Whois по домену в подписи можно посмотреть.

Тоже располагаю один из сайтов у этого хостера (сайт на WP + форум phpBB, на обоих движках много плагинов и модов), посетителей даже чуть больше. Никаких замечаний по нагрузке или другим вещам мне пока не делали.
Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 13159
Стаж: 15 лет 1 месяц
Благодарил (а): 236 раз
Поблагодарили: 3750 раз

Re: Хостер обвиняет в нагрузке на сервер.

Сообщение Татьяна5 »

Вывод - приводить в порядок код.
Аватара пользователя
staiki
phpBB 2.0.2
Сообщения: 318
Стаж: 14 лет 3 месяца
Откуда: Киев Украина
Благодарил (а): 76 раз
Поблагодарили: 9 раз
Забанен: Бессрочно

Re: Хостер обвиняет в нагрузке на сервер.

Сообщение staiki »

Спасибо всем за советы.Но честно сказать ничего не понял.
http://staiki.net/index.php Форум Компьютерная Помощь
Аватара пользователя
Пчелкин
phpBB 3.3.0
Сообщения: 11362
Стаж: 16 лет 8 месяцев
Благодарил (а): 1832 раза
Поблагодарили: 1358 раз

Re: Хостер обвиняет в нагрузке на сервер.

Сообщение Пчелкин »

Татьяна5 писал(а):Вывод - приводить в порядок код.
Добавлено спустя 1 минуту 55 секунд:
Почитай, например, про зацикленные запросы без ответов от сервака (запрос-недолет-нет ответа-повтор)... Про вечно зацикленные... Там и про остальное пишется
NIKON-D90, AF-S 18-105, AF-S 14-24, AF-S 24-70
Аватара пользователя
staiki
phpBB 2.0.2
Сообщения: 318
Стаж: 14 лет 3 месяца
Откуда: Киев Украина
Благодарил (а): 76 раз
Поблагодарили: 9 раз
Забанен: Бессрочно

Re: Хостер обвиняет в нагрузке на сервер.

Сообщение staiki »

Пчелкин писал(а): Про вечно зацикленные...
Где это смотреть-дай ссылку если вкурсе.
http://staiki.net/index.php Форум Компьютерная Помощь
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 17272
Стаж: 20 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 632 раза
Поблагодарили: 2412 раз

Re: Хостер обвиняет в нагрузке на сервер.

Сообщение rxu »

staiki
Хостер в ответе дал вам какой-то мусор. Браузерные ошибки никакого отношения к нагрузке на сервер не имеют.
Должны дать конкретные скрипты и/или запросы SQL с завышенным потреблением ресурсов, на то она и техподдержка.
Изображение
Аватара пользователя
staiki
phpBB 2.0.2
Сообщения: 318
Стаж: 14 лет 3 месяца
Откуда: Киев Украина
Благодарил (а): 76 раз
Поблагодарили: 9 раз
Забанен: Бессрочно

Re: Хостер обвиняет в нагрузке на сервер.

Сообщение staiki »

Пчелкин писал(а):Как вариант - садиться на Денвер и спокойно и скурпулезно править все ошибки в верстке...
Мне человек который разбирается в этом сделал всё что мог ещё месяца два назад и после всё было нормально.Это всё началось после какого-то сбоя на серваке в хостера и начались проблемы.Одно время я писал за вирусы что хостер жаловался и они были в папке кеш.Но как потом разобрались это антивирус ложно срабатывал на мод какой-то по кешам.Сейчас опять вдруг пробема якобы движка по мыслям хостера.

rxu
Я и просил их об этом.Результат ответа в шапке.

Добавлено спустя 2 минуты 13 секунд:
Anvar писал(а):Трекер сам по себе нагрузку дает не хилую, а тут еще код не хороший.
У меня не треккер-обычный форум.
http://staiki.net/index.php Форум Компьютерная Помощь
Аватара пользователя
Пчелкин
phpBB 3.3.0
Сообщения: 11362
Стаж: 16 лет 8 месяцев
Благодарил (а): 1832 раза
Поблагодарили: 1358 раз

Re: Хостер обвиняет в нагрузке на сервер.

Сообщение Пчелкин »

Например на хабре есть много...вот хотябы - http://habrahabr.ru/post/109116/
У VEGа на форуме тож много читал
NIKON-D90, AF-S 18-105, AF-S 14-24, AF-S 24-70
Аватара пользователя
staiki
phpBB 2.0.2
Сообщения: 318
Стаж: 14 лет 3 месяца
Откуда: Киев Украина
Благодарил (а): 76 раз
Поблагодарили: 9 раз
Забанен: Бессрочно

Re: Хостер обвиняет в нагрузке на сервер.

Сообщение staiki »

Пчелкин писал(а):Например на хабре есть много...вот хотябы
То я не пойму-проблема на сайте у меня в шаблонах или у хостера?
http://staiki.net/index.php Форум Компьютерная Помощь
Аватара пользователя
xisp
phpBB 3.0.0 RC7
Сообщения: 1798
Стаж: 14 лет 4 месяца
Благодарил (а): 152 раза
Поблагодарили: 215 раз
Забанен: Бессрочно

Re: Хостер обвиняет в нагрузке на сервер.

Сообщение xisp »

staiki писал(а):Если запустить отладчик в браузере, клик правой кнопкой и исследовать элемент, видно много нарушений в работе, которые также могут приводить к чрезмерной нагрузке и зависанию скриптов.
Ох лол, вот это ржака.
В общем они вам тонко намекают на переход на более дорогой тариф. Развод на бабки по хостеровски.
staiki писал(а):То я не пойму-проблема на сайте у меня в шаблонах или у хостера?
И там и там. Хостер не желает держать мало мальскую нагрузку, а ваши скрипты не самые оптимальные. В данном случаи проще переехать на более дорогой тариф или на другой хостинг, нежели чем разбираться в скриптах.
phpBBex
Аватара пользователя
staiki
phpBB 2.0.2
Сообщения: 318
Стаж: 14 лет 3 месяца
Откуда: Киев Украина
Благодарил (а): 76 раз
Поблагодарили: 9 раз
Забанен: Бессрочно

Re: Хостер обвиняет в нагрузке на сервер.

Сообщение staiki »

xisp писал(а):Ох лол, вот это ржака.
В общем они вам тонко намекают на переход на более дорогой тариф. Развод на бабки по хостеровски.
Да я если честно тоже пришел к этому выводу)))Я и написал им что намекать на переход на более дорогой тариф бесполезно.
Ответили уже так:
Скрытый текст
В данный момент процессы на Вашей услуге потребляют ресурсы в пределах нормы. Пожалуйста, напишите нам при возобновлении проблемы.
Спасибо всем за советы.Можно закрывать тему.
http://staiki.net/index.php Форум Компьютерная Помощь

Вернуться в «Поддержка phpBB 3.0.х»