[3.1] [3.1.10] Обязательный модуль не существует. Исправление

Поддержка расширений, созданных авторами не из нашего сообщества, а также любые вопросы, связанные с расширениями для phpBB, кроме относящихся к форуму Для авторов.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Мини [FAQ] по phpBB3.1.x/3.2.x | FAQ | Внимание! Прежде чем создать тему - прочти! | Как задавать вопросы | Как устанавливать расширения

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
Sheer
phpBB Guru
phpBB Guru
Сообщения: 11481
Зарегистрирован: 18.02.2007 19:01
Откуда: Калининград не Кенигсберг
Благодарил (а): 53 раза
Поблагодарили: 2573 раза
Контактная информация:

[3.1] [3.1.10] Обязательный модуль не существует. Исправление

Сообщение Sheer » 15.12.2016 13:16

В версии 3.1.10 допущена ошибка, которая приводит к тому, что невозможно установить расширения, имеющие в своем составе дополнительные модули личного, модераторского или администраторского разделов.
Решение проблемы.
1. Открыть в редакторе файл \phpbb\db\migration\tool\module.php
2. Перейти по ссылке
В окне браузера выделить и скопировать в буфер обмена весь появившийся текст (Ctrl+A затем Ctrl+C)
3. В редакторе заменить весть текст на текст из буфера обмена Ctrl+A затем Ctrl+V
4. Сохранить файл Ctrl+S
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.

Аватара пользователя
DeathMan
phpBB 2.0.7a
Сообщения: 633
Зарегистрирован: 12.05.2007 0:38
Откуда: Курская обл.
Благодарил (а): 73 раза
Поблагодарили: 8 раз
Контактная информация:

Re: [3.1.10] Обязательный модуль не существует. Исправление

Сообщение DeathMan » 27.12.2016 8:50

Это всем делать надо кто ставит расширения на данную версию движка ?
phpbb3 - сила!

Аватара пользователя
Siava
Поддержка
Поддержка
Сообщения: 4166
Зарегистрирован: 11.01.2005 14:29
Откуда: Питер
Благодарил (а): 109 раз
Поблагодарили: 435 раз
Контактная информация:

Re: [3.1.10] Обязательный модуль не существует. Исправление

Сообщение Siava » 27.12.2016 10:30

DeathMan, да. Это одно из исправлений для 3.1.10.
Еще одно нарушение правил и будете забанены. © Mr. Anderson
https://siava.ru/forum/ (phpbb 2.0.x, 3.1.x 3.2.x)

Аватара пользователя
DeathMan
phpBB 2.0.7a
Сообщения: 633
Зарегистрирован: 12.05.2007 0:38
Откуда: Курская обл.
Благодарил (а): 73 раза
Поблагодарили: 8 раз
Контактная информация:

Re: [3.1.10] Обязательный модуль не существует. Исправление

Сообщение DeathMan » 27.12.2016 13:24

а чего его официально не исправят, например доведя версию 3.1.10 до 3.1.11 или это слишком для смены билда ?
phpbb3 - сила!

Аватара пользователя
Sheer
phpBB Guru
phpBB Guru
Сообщения: 11481
Зарегистрирован: 18.02.2007 19:01
Откуда: Калининград не Кенигсберг
Благодарил (а): 53 раза
Поблагодарили: 2573 раза
Контактная информация:

Re: [3.1.10] Обязательный модуль не существует. Исправление

Сообщение Sheer » 27.12.2016 15:27

Это официальное исправление, которое включено в версию 3.1.11.
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.

Аватара пользователя
DeathMan
phpBB 2.0.7a
Сообщения: 633
Зарегистрирован: 12.05.2007 0:38
Откуда: Курская обл.
Благодарил (а): 73 раза
Поблагодарили: 8 раз
Контактная информация:

Re: [3.1.10] Обязательный модуль не существует. Исправление

Сообщение DeathMan » 27.12.2016 19:33

странно... 
2016-12-27_19-32-29.png
phpbb3 - сила!

Аватара пользователя
Sumanai
phpBB 3.0.0 RC5
Сообщения: 1664
Зарегистрирован: 02.11.2014 13:57
Благодарил (а): 267 раз
Поблагодарили: 219 раз
Контактная информация:

Re: [3.1.10] Обязательный модуль не существует. Исправление

Сообщение Sumanai » 27.12.2016 19:58

С такими багами версию 3.1.11 нужно было выпускать через 3 дня после выхода 3.1.10. А 3.1.11 до сих пор нет.

Аватара пользователя
DeathMan
phpBB 2.0.7a
Сообщения: 633
Зарегистрирован: 12.05.2007 0:38
Откуда: Курская обл.
Благодарил (а): 73 раза
Поблагодарили: 8 раз
Контактная информация:

Re: [3.1.10] Обязательный модуль не существует. Исправление

Сообщение DeathMan » 27.12.2016 20:00

так что, еще есть баги ?
phpbb3 - сила!

Аватара пользователя
Sumanai
phpBB 3.0.0 RC5
Сообщения: 1664
Зарегистрирован: 02.11.2014 13:57
Благодарил (а): 267 раз
Поблагодарили: 219 раз
Контактная информация:

Re: [3.1.10] Обязательный модуль не существует. Исправление

Сообщение Sumanai » 27.12.2016 20:04

Да, я правда всех уже не упомню, но поискать можно.

Отправлено спустя 31 секунду:
Вообще- жутко забагованная версия, никому её не советую ставить и сам не ставлю.

Аватара пользователя
DeathMan
phpBB 2.0.7a
Сообщения: 633
Зарегистрирован: 12.05.2007 0:38
Откуда: Курская обл.
Благодарил (а): 73 раза
Поблагодарили: 8 раз
Контактная информация:

Re: [3.1.10] Обязательный модуль не существует. Исправление

Сообщение DeathMan » 27.12.2016 20:14

А я решался год наверное на переход. :( Блин... Что так все плохо ?
phpbb3 - сила!

Аватара пользователя
Sheer
phpBB Guru
phpBB Guru
Сообщения: 11481
Зарегистрирован: 18.02.2007 19:01
Откуда: Калининград не Кенигсберг
Благодарил (а): 53 раза
Поблагодарили: 2573 раза
Контактная информация:

Re: [3.1.10] Обязательный модуль не существует. Исправление

Сообщение Sheer » 27.12.2016 21:06

DeathMan, чего странного вы нашли? Версия 3.1.10 на сегодняшний день является новейшей. 3.1.11 еще не вышла.
DeathMan писал(а): А я решался год наверное на переход
Сделайте даунгрейд до версии 3.1.9. Как это сделать я писал на форуме.
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.

Аватара пользователя
DeathMan
phpBB 2.0.7a
Сообщения: 633
Зарегистрирован: 12.05.2007 0:38
Откуда: Курская обл.
Благодарил (а): 73 раза
Поблагодарили: 8 раз
Контактная информация:

Re: [3.1.10] Обязательный модуль не существует. Исправление

Сообщение DeathMan » 27.12.2016 22:44

Ни ни, никаких даундэндингов.... Ни ни... Бог с вами батенька...
phpbb3 - сила!

Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 14490
Зарегистрирован: 12.05.2006 18:16
Откуда: Красноярск
Благодарил (а): 347 раз
Поблагодарили: 1546 раз
Контактная информация:

Re: [3.1.10] Обязательный модуль не существует. Исправление

Сообщение rxu » 28.12.2016 19:45

Подождите 10 дней,и сделайте апгрейд до 3.2.
Изображение

Ответить

Вернуться в «Поддержка расширений для phpBB»