Ошибка 500 после очистки кеша

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
LavIgor
Former team member
Сообщения: 3468
Стаж: 12 лет 4 месяца
Благодарил (а): 41 раз
Поблагодарили: 935 раз

Re: Ошибка 500 после очистки кеша

Сообщение LavIgor »

InTheWeb писал(а): phpBB ошибки даже вывести не может.
phpBB с этим не связан, к тому же у Вас устаревшая версия, вышедшая больше пяти лет назад.
Можете попробовать обновиться, повод есть.

Ошибки просто так не возникают.

P.S. Если хотите, можете дать доступы в ЛС. Причину можно отследить.
Аватара пользователя
InTheWeb
phpBB 1.4.0
Сообщения: 31
Стаж: 11 лет
Благодарил (а): 14 раз
Поблагодарили: 3 раза

Re: Ошибка 500 после очистки кеша

Сообщение InTheWeb »

Доброе утро.
Проблему решил... Оказалось, что папка hooks анализируется движком и автоматически подключает имеющиеся в папке модули.
Исправил ошибку с помощь условия function_exists.
Благодарю всех за поддержку.
Аватара пользователя
keke
phpBB 1.4.1
Сообщения: 47
Стаж: 12 лет 11 месяцев
Откуда: Москва
Благодарил (а): 29 раз

Re: Ошибка 500 после очистки кеша

Сообщение keke »

Приветствую

Столкнулся с такой же проблемой - проводил обновление модулей на форуме (с официального сайта). После обновления очистил кеш.
При попытке зайти на страницу форума получаю ошибку HTTP ERROR 500

Подскажите как эту ошибку побороть.

Перечитал тему, но не нашел для себя решения, а решение которое помогло InTheWeb мне не понятно, вероятно в силу того что я не настолько хорошо владею знаниями по работе с phpbb
Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 13159
Стаж: 15 лет 1 месяц
Благодарил (а): 236 раз
Поблагодарили: 3750 раз

Re: Ошибка 500 после очистки кеша

Сообщение Татьяна5 »

keke, что пишет в логе ошибок (error_log)?
Аватара пользователя
keke
phpBB 1.4.1
Сообщения: 47
Стаж: 12 лет 11 месяцев
Откуда: Москва
Благодарил (а): 29 раз

Re: Ошибка 500 после очистки кеша

Сообщение keke »

Татьяна5, уже понимаю что в моем ответе содержится проблема, но не приложу ума как бороться с ней

Код: Выделить всё

[Thu Nov 10 23:38:07.582637 2016] [:error] [pid 28853] [client ] PHP Fatal error:  Call to undefined method classTTConnection::calcSwitchOptions() in www/forumnew/ext/tapatalk/tapatalk/event/main_listener.php on line 225
Модуль тапаталка я тоже обновлял, так как он ругался что устарел.
Аватара пользователя
Mr. Anderson
phpBB Guru
phpBB Guru
Сообщения: 7522
Стаж: 22 года 6 месяцев
Откуда: СССР
Благодарил (а): 6 раз
Поблагодарили: 154 раза

Re: Ошибка 500 после очистки кеша

Сообщение Mr. Anderson »

keke писал(а): tapatalk
Адовая глюкавая нафиг не нужная хрень.
keke писал(а): я тоже обновлял
Как именно?
Аватара пользователя
keke
phpBB 1.4.1
Сообщения: 47
Стаж: 12 лет 11 месяцев
Откуда: Москва
Благодарил (а): 29 раз

Re: Ошибка 500 после очистки кеша

Сообщение keke »

Mr. Anderson писал(а): Адовая глюкавая нафиг не нужная хрень.
Благодарю за ожидаемое мнение.
Mr. Anderson писал(а): Как именно?
Через обновление расширений в панели администрирования, ошибок не было.
Аватара пользователя
Mr. Anderson
phpBB Guru
phpBB Guru
Сообщения: 7522
Стаж: 22 года 6 месяцев
Откуда: СССР
Благодарил (а): 6 раз
Поблагодарили: 154 раза

Re: Ошибка 500 после очистки кеша

Сообщение Mr. Anderson »

keke, конкретно порядок действий опишите.
Аватара пользователя
keke
phpBB 1.4.1
Сообщения: 47
Стаж: 12 лет 11 месяцев
Откуда: Москва
Благодарил (а): 29 раз

Re: Ошибка 500 после очистки кеша

Сообщение keke »

Mr. Anderson, порядок действий был таков:
Скачал архив с новой версией с сайта https://tapatalk.com/download_phpbb.php
Воспользовался автомодом для загрузки архива
После успешного обновления активировал расширение тапаталка
Очистил кеш форума используя (при помощи кнопки в первой вкладке панели администрирования)
Аватара пользователя
Mr. Anderson
phpBB Guru
phpBB Guru
Сообщения: 7522
Стаж: 22 года 6 месяцев
Откуда: СССР
Благодарил (а): 6 раз
Поблагодарили: 154 раза

Re: Ошибка 500 после очистки кеша

Сообщение Mr. Anderson »

Так, стоп.
keke писал(а): обновлял
Так обновляли или с нуля ставили? Судя по описанному процессу - с нуля.
keke писал(а): автомодом для загрузки
Чем-чем? Какой АМ на 3.1? :?

Ниччего не понимаю (с)
Аватара пользователя
keke
phpBB 1.4.1
Сообщения: 47
Стаж: 12 лет 11 месяцев
Откуда: Москва
Благодарил (а): 29 раз

Re: Ошибка 500 после очистки кеша

Сообщение keke »

Mr. Anderson писал(а): Так обновляли или с нуля ставили? Судя по описанному процессу - с нуля.
Обновлял, до этого стояла версия 1.3.5 (если это имеет значение).
Mr. Anderson писал(а): Чем-чем? Какой АМ на 3.1?
Прошу прощения, конечно не автомод (ночное время сказывается), не знаю как правильно называть менеджер которым обновляются моды, вот через этот раздел админки:
http://take.ms/ybTKP
Аватара пользователя
Mr. Anderson
phpBB Guru
phpBB Guru
Сообщения: 7522
Стаж: 22 года 6 месяцев
Откуда: СССР
Благодарил (а): 6 раз
Поблагодарили: 154 раза

Re: Ошибка 500 после очистки кеша

Сообщение Mr. Anderson »

keke писал(а): Обновлял
А процесс описанный не похож на обновление. Еще и про АМ догадываться надо - что там, куда, где вы делали. Испрошено же
Mr. Anderson писал(а): конкретно порядок действий опишите
keke писал(а): через этот раздел админки
Upload Extensions
Сторонний, кстати, компонент.

PS:
К слову, какая версия phpBB?
Аватара пользователя
keke
phpBB 1.4.1
Сообщения: 47
Стаж: 12 лет 11 месяцев
Откуда: Москва
Благодарил (а): 29 раз

Re: Ошибка 500 после очистки кеша

Сообщение keke »

Mr. Anderson писал(а): К слову, какая версия phpBB?
3.1.8

Отправлено спустя 43 секунды:
Mr. Anderson, возможно вы сможете подсказать мне варианты действий чтобы избавиться от проблемы?
Аватара пользователя
LavIgor
Former team member
Сообщения: 3468
Стаж: 12 лет 4 месяца
Благодарил (а): 41 раз
Поблагодарили: 935 раз

Re: Ошибка 500 после очистки кеша

Сообщение LavIgor »

keke писал(а): classTTConnection
А этот классТТКоннекшн присутствует в файлах новой версии?
На ресурсе Tapatalk подобной проблемы не нашли?
Аватара пользователя
keke
phpBB 1.4.1
Сообщения: 47
Стаж: 12 лет 11 месяцев
Откуда: Москва
Благодарил (а): 29 раз

Re: Ошибка 500 после очистки кеша

Сообщение keke »

LavIgor писал(а): А этот классТТКоннекшн присутствует в файлах новой версии?
Такой файл там действительно присутствует.
LavIgor писал(а): На ресурсе Tapatalk подобной проблемы не нашли?
Именно с этим классом проблемы не нашел, но есть схожая проблема с 500й ошибкой, но с другим файлом и другим текстом ошибки в логе. В любом случае представители саппорта тапаталка всегда указывают в итоге - "переустановите".

Вот только как переустановить если админка не работает. По идее можно просто вырезать его целиком и залить через фтп, но не уверен что это поможет. Поэтому и написал в этой теме.

Вернуться в «Поддержка phpBB 3.0.х»