Уважаемые пользователи!
C 7 ноября 2020 года phpBB Group прекратила выпуск обновлений и завершила дальнейшее развитие phpBB версии 3.2.
С 1 августа 2024 года phpBB Group прекращает поддержку phpBB 3.2 на официальном сайте.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.2 до 31 декабря 2024 года.
С учетом этого, настоятельно рекомендуется обновить конференции до версии 3.3.

Вышел phpBB 3.3.0 [обсуждаем]

Проблемы с установкой или работой phpBB 3.3.x? Получите помощь здесь!
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Мини [FAQ] по phpBB 3.1.x/3.2.x | FAQ | Как задавать вопросы | Как устанавливать расширения

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
Siava
Поддержка
Поддержка
Сообщения: 5300
Стаж: 19 лет 5 месяцев
Откуда: Питер
Благодарил (а): 189 раз
Поблагодарили: 803 раза

Re: Вышел phpBB 3.3.0 [обсуждаем]

Сообщение Siava »

dnk, как бы ничего нового, не знаю на что вы надеялись в этот раз. Каждое такое обновление версии движка повышает системные требования и есть вероятность потерять совместимость некоторых расширений. Поэтому не стоит обновлять движок не убедившись, что всё будет работать в новой версии.
Еще одно нарушение правил и будете забанены. © Mr. Anderson
Ты очистил кеш? © Sheer
https://siava.ru (phpbb 2.0.x 3.5.x)
Аватара пользователя
demonlibra
phpBB 2.0.2
Сообщения: 338
Стаж: 14 лет 7 месяцев
Откуда: Ростов-на-Дону
Благодарил (а): 24 раза
Поблагодарили: 38 раз

Re: Вышел phpBB 3.3.0 [обсуждаем]

Сообщение demonlibra »

dnk писал(а): 19.03.2020 21:50 Может сразу php 9.x, че тянуть-то с обломом десятков тысяч людей?
Если слово "тысяч" убрать, фраза станет верной.
Аватара пользователя
Nekstati
Поддержка
Поддержка
Сообщения: 3336
Стаж: 15 лет 3 месяца
Благодарил (а): 25 раз
Поблагодарили: 592 раза

Re: Вышел phpBB 3.3.0 [обсуждаем]

Сообщение Nekstati »

dnk, demonlibra, и так тянули очень долго, php5 уже пару лет как не поддерживается, да и заявленный в требованиях php7.1 тоже уже малость устарел. :)

Отвал расширений у dnk не связан с версией PHP, там в чём-то другом проблема. Многие из этих расширений и на php7.3 работают нормально.
Аватара пользователя
KEMnEP
phpBB 2.0.17
Сообщения: 1133
Стаж: 9 лет 2 месяца
Благодарил (а): 43 раза
Поблагодарили: 288 раз

Re: Вышел phpBB 3.3.0 [обсуждаем]

Сообщение KEMnEP »

Nekstati писал(а): 20.03.2020 14:45 и на php7.3 работают нормально
и на php 7.4
Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 12478
Стаж: 12 лет 10 месяцев
Благодарил (а): 166 раз
Поблагодарили: 2494 раза

Re: Вышел phpBB 3.3.0 [обсуждаем]

Сообщение Татьяна5 »

Nekstati писал(а): 20.03.2020 14:45 в чём-то другом
Symphony обновили, что тоже неплохо

Отправлено спустя 2 минуты 20 секунд:
dnk, прежде чем обновляться почитайте и разберитесь, надо ли это вам
phpBB 3.2.9 и 3.3.0 ничем, кроме поддержки новых версий php (в это входит обновление некоторых компонентов движка), не отличаются
Аватара пользователя
ronim
Модератор
Модератор
Сообщения: 917
Стаж: 6 лет 5 месяцев
Откуда: Таллин ,Эстония
Благодарил (а): 168 раз
Поблагодарили: 162 раза

Re: Вышел phpBB 3.3.0 [обсуждаем]

Сообщение ronim »

dnk, Тут вопрос с какой версии перескочить ? на 3.3.0
Если ты не видишь проблем на форуме , но это не значить что их там нет
dnk
phpBB 2.0.4
Сообщения: 431
Стаж: 17 лет 9 месяцев
Благодарил (а): 7 раз
Поблагодарили: 1 раз

Re: Вышел phpBB 3.3.0 [обсуждаем]

Сообщение dnk »

Запуск чистого 3.3.0 ru на php 7.0 и, разумеется, die()
You are running an unsupported PHP version. Please upgrade to PHP 7.1.3 or higher before trying to install or update to phpBB 3.3
Разумеется, далее includes/startup.php и долой:

Код: Выделить всё

if (version_compare(PHP_VERSION, '7.1.3', '<'))
{
	die('You are running an unsupported PHP version. Please upgrade to PHP 7.1.3 or higher before trying to install or update to phpBB 3.3');
}
далее, что вполне понятно, вся эта симфония вместе с композитором отвалилась:

Код: Выделить всё

Parse error: syntax error, unexpected 'finally' (T_STRING), expecting catch (T_CATCH) in /home/.../.../forums/vendor/symfony/dependency-injection/Extension/Extension.php on line 107
- и это после сгенерированного на php 7.3 и вновь очищенного кеша с опенингом на php 7.0. А, если без генерации первоначального кеша, так, вообще, пол-страницы бреда от ocramius.
Не, ребят, это так просто от неф делать, авось, огонь вспыхнет...
Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 12478
Стаж: 12 лет 10 месяцев
Благодарил (а): 166 раз
Поблагодарили: 2494 раза

Re: Вышел phpBB 3.3.0 [обсуждаем]

Сообщение Татьяна5 »

dnk, да, вам сразу писали, что минимальная версия php для 3.3.0 - 7.1.3. Пытаться запустить 3.3.0 на версиях php ниже нет смысла
dnk
phpBB 2.0.4
Сообщения: 431
Стаж: 17 лет 9 месяцев
Благодарил (а): 7 раз
Поблагодарили: 1 раз

Re: Вышел phpBB 3.3.0 [обсуждаем]

Сообщение dnk »

Вообще, что хочу сказать: уже лет 15 занимаясь модификацией версий phpbb, к сожалению, прихожу к выводу, что разработчики де-факто превращают движок в инвалида - он все более требовательный, на многих системах, даже не таких уж старых, работает "с сапом", открывается и устанавливается очень медленно, файлов в дистрибутиве - немерено. Как бы не получилось как в том мультике про Вовку в тридевятом царстве, когда он насовал дров в печку, что та аж и ахнула, а что было дальше, я думаю помните, - взрыв котла - "А, и так сойдет". Так и здесь заплагинили движок все больше и больше (конечно, все раньше мечтали о высокой функциональности), а некоторые вещи, как правильно выше указали, оставили на уровне деревни и не включили в базовый пакет. Вот и получили, что имеем.
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 16464
Стаж: 18 лет 1 месяц
Откуда: Красноярск
Благодарил (а): 533 раза
Поблагодарили: 1773 раза

Re: Вышел phpBB 3.3.0 [обсуждаем]

Сообщение rxu »

dnk, всё относительно, смотря на чем вы его запускаете. В большинстве случаев нормально работает даже на недорогих облачных хостингах.
Изображение
max2012
phpBB 2.0.0
Сообщения: 242
Стаж: 12 лет
Благодарил (а): 1 раз
Поблагодарили: 3 раза

Re: Вышел phpBB 3.3.0 [обсуждаем]

Сообщение max2012 »

Только сейчас заметил у себя на форуме, не найду настройку статус пользователя, она разве настраивается?
Как на этом форуме, в профиле под аватарой - Администратор, Поддержка и тд.
Аватара пользователя
Nekstati
Поддержка
Поддержка
Сообщения: 3336
Стаж: 15 лет 3 месяца
Благодарил (а): 25 раз
Поблагодарили: 592 раза

Re: Вышел phpBB 3.3.0 [обсуждаем]

Сообщение Nekstati »

max2012
phpBB 2.0.0
Сообщения: 242
Стаж: 12 лет
Благодарил (а): 1 раз
Поблагодарили: 3 раза

Re: Вышел phpBB 3.3.0 [обсуждаем]

Сообщение max2012 »

Понял причину. Если установить чистый форум, то звание Администратор прописывается уже по дефолту. У меня обновленный форум и раньше не было таких званий, поэтому и сейчас нет...
Аватара пользователя
romaamor
phpBB 3.0.3
Сообщения: 2171
Стаж: 12 лет 2 месяца
Откуда: Одесса
Благодарил (а): 626 раз
Поблагодарили: 144 раза

Re: Вышел phpBB 3.3.0 [обсуждаем]

Сообщение romaamor »

Доброй ночи. Скажите а почему в этой версии, у меня, если включить расширение оно срабатывает, всё пашет. Но потом если его отключить, то второй раз оно не включается ? Просто перезагружается страница. Любое расширение.

Отправлено спустя 25 минут 8 секунд:
Очистил кеш, все те несколько расширений, что были включены - отключились.
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 16464
Стаж: 18 лет 1 месяц
Откуда: Красноярск
Благодарил (а): 533 раза
Поблагодарили: 1773 раза

Re: Вышел phpBB 3.3.0 [обсуждаем]

Сообщение rxu »

Нет подобной проблемы на чистой установке. Смотрите, что на вашей конкретной борде не так.
Изображение

Вернуться в «Поддержка phpBB 3.3.x»