Внимание!
Не все расширения для phpBB 3.2 совместимы с phpBB 3.3, главным образом из-за неверного синтаксиса в определениях сервисов (отсутствия обрамляющих кавычек - '...').
Перед обновлением необходимо убедиться в совместимости всех расширений.
Рекомендуется предварительно тестировать обновление на копии конференции (локально или на сервере).

[3.3] Несовместимые расширения

Проблемы с установкой или работой phpBB 3.3.x? Получите помощь здесь!
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Мини [FAQ] по phpBB 3.1.x/3.2.x | FAQ | Как задавать вопросы | Как устанавливать расширения

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 14744
Зарегистрирован: 12.05.2006 18:16
Откуда: Красноярск
Благодарил (а): 354 раза
Поблагодарили: 1623 раза

[3.3] Несовместимые расширения

Сообщение rxu »

Каталог несовместимых с phpBB 3.3 на настоящий момент расширений.Тестировалось в связке phpBB 3.3 / PHP 7.4.
Принимаются добавления в список (с описанием того, что не работает).
Изображение

Перенесено из форума Анонсы и поддержка расширений для phpBB в форум Поддержка phpBB 3.3.x 12.01.2020 10:47 модератором rxu

Аватара пользователя
Sheer
phpBB Guru
phpBB Guru
Сообщения: 11541
Зарегистрирован: 18.02.2007 19:01
Откуда: Калининград не Кенигсберг
Благодарил (а): 53 раза
Поблагодарили: 2594 раза

Re: [3.3] Несовместимые расширения

Сообщение Sheer »

globalnoises писал(а):
14.01.2020 15:48
ковычками
Кавычками, едрёна лапоть!
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.

VPN
phpBB 1.2.1
Сообщения: 22
Зарегистрирован: 20.01.2017 20:24
Благодарил (а): 2 раза
Поблагодарили: 1 раз

Re: [3.3] Несовместимые расширения

Сообщение VPN »

rxu писал(а):
06.01.2020 16:11
Принимаются добавления в список (с описанием того, что не работает).
Поставил 3.3 на ОпенСервер, СУБД 2.8 с реального форума, обновлена до 3.3
OpenServer
MySQL(i) 10.3.9-MariaDB
Версия PHP: 7.2.10
Версия phpBB: 3.3.0

Не работают некоторые расширения. Показывает ошибку в панели "Персонализация" 9-10 пунктов в зависимости от расширения.
 
Произошла ошибка phpBB при компиляции контейнера, связанная с одним из установленных расширений. По этой причине, все установленные расширения были временно отключены. Попробуйте очистить кэш конференции. Все расширения будут автоматически включены, если ошибка контейнера будет устранена. В противном случае, обратитесь на сайт официальной русской поддержки phpBB Guru для получения помощи.

Исключение: The file "D:\OSPanel\domains\.com\support\ext\rxu\FirstPostOnEveryPage\config\services.yml" does not contain valid YAML: The reserved indicator "@" cannot start a plain scalar; you need to quote the scalar at line 5 (near "- @dbal.conn").

#0 D:\OSPanel\domains\.com\support\vendor\symfony\dependency-injection\Loader\YamlFileLoader.php(117): Symfony\Component\DependencyInjection\Loader\YamlFileLoader->loadFile('D:\\OSPanel\\doma...')
#1 D:\OSPanel\domains\.com\support\phpbb\extension\di\extension_base.php(99): Symfony\Component\DependencyInjection\Loader\YamlFileLoader->load('services.yml')
#2 D:\OSPanel\domains\.com\support\phpbb\extension\di\extension_base.php(63): phpbb\extension\di\extension_base->load_services(Object(Symfony\Component\DependencyInjection\Compiler\MergeExtensionConfigurationContainerBuilder))
#3 D:\OSPanel\domains\.com\support\vendor\symfony\dependency-injection\Compiler\MergeExtensionConfigurationPass.php(71): phpbb\extension\di\extension_base->load(Array, Object(Symfony\Component\DependencyInjection\Compiler\MergeExtensionConfigurationContainerBuilder))
#4 D:\OSPanel\domains\.com\support\vendor\symfony\http-kernel\DependencyInjection\MergeExtensionConfigurationPass.php(39): Symfony\Component\DependencyInjection\Compiler\MergeExtensionConfigurationPass->process(Object(Symfony\Component\DependencyInjection\ContainerBuilder))
#5 D:\OSPanel\domains\.com\support\vendor\symfony\dependency-injection\Compiler\Compiler.php(140): Symfony\Component\HttpKernel\DependencyInjection\MergeExtensionConfigurationPass->process(Object(Symfony\Component\DependencyInjection\ContainerBuilder))
#6 D:\OSPanel\domains\.com\support\vendor\symfony\dependency-injection\ContainerBuilder.php(789): Symfony\Component\DependencyInjection\Compiler\Compiler->compile(Object(Symfony\Component\DependencyInjection\ContainerBuilder))
#7 D:\OSPanel\domains\.com\support\phpbb\di\container_builder.php(203): Symfony\Component\DependencyInjection\ContainerBuilder->compile()
#8 D:\OSPanel\domains\.com\support\common.php(115): phpbb\di\container_builder->get_container()
#9 D:\OSPanel\domains\.com\support\adm\index.php(23): require('D:\\OSPanel\\doma...')
#10 {main}
Не работают расширения:
First post on every page
Nv who was here
phpBB.de - Move Message
phpbb 3.2 WYSIWYG BBCode Editor
PM Spy 1.0.1
Popup PM
Poster IP in Viewtopic

Не понял, что имелось ввиду вот здесь (видимо для версия PHP: 7.4) у меня решилось так:
\boardtools\upload
services.yml
arguments:
- '@user'


First post on every page
services.yml
 
arguments:
- '@dbal.conn'
- '@auth'
- '@request'
- '@template'
- '@user'
Nv who was here
services.yml
 
arguments:
- '@template'
- '@config'
- '@user'
- '@auth'
- '@dbal.conn'
- '%core.table_prefix%'
bb3mobi.washere.listener:
class: bb3mobi\washere\event\listener
arguments:
- '@bb3mobi.washere.helper'
так же в phpBB.de - Move Message
services.yml
 
arguments:
- '@auth'
- '@content.visibility'
- '@dbal.conn'
- '@template'
- '@user'
- '%core.root_path%'
- '%core.php_ext%'
phpbb 3.2 WYSIWYG BBCode Editor
services.yml
 
arguments:
- '@dbal.conn'
- '@template'
- '@config'
- '@user'
- '%core.root_path%'
Poster IP in Viewtopic
services.yml
 
arguments:
- '@auth'
PM Spy 1.0.1
services.yml
 
arguments:
- '@dbal.conn'
- '@user'
Popup PM
services.yml
 
arguments:
- '@config'
- '@template'
- '@user'
- '@dbal.conn'
- '@request'
- '%core.root_path%'
- '%core.php_ext%'

Аватара пользователя
KEMnEP
phpBB 2.0.11
Сообщения: 833
Зарегистрирован: 22.03.2015 16:32
Благодарил (а): 35 раз
Поблагодарили: 202 раза

Re: [3.3] Несовместимые расширения

Сообщение KEMnEP »

Profile side switcher - выдаёт ошибку.
QuickReply Reloaded - по словам автора пока не совместим.
Остальное уже отлажено в основном '...' и path:. Но эти 2 важных расширения стопорят переход мой на 3.3

Аватара пользователя
LavIgor
Поддержка
Поддержка
Сообщения: 3459
Зарегистрирован: 28.04.2014 8:16
Благодарил (а): 39 раз
Поблагодарили: 927 раз

Re: [3.3] Несовместимые расширения

Сообщение LavIgor »

KEMnEP, насчёт первого, пробуйте обновить из репозитория. Зарубежные товарищи сказали, что та версия у них работает на 3.3.
Правки подоспеют уже в скором времени, прошу прощения за неоперативность в этом вопросе.

Аватара пользователя
ronim
phpBB 2.0.3
Сообщения: 390
Зарегистрирован: 10.01.2018 20:24
Откуда: Таллин ,Эстония
Благодарил (а): 100 раз
Поблагодарили: 60 раз

Re: [3.3] Несовместимые расширения

Сообщение ronim »

LavIgor,
Зарубежные товарищи сказали
это что про меня?
KEMnEP, В другой теме
 
tyson писал(а):
10.01.2020 16:07
День добрый. А как же тогда быть с 3.3.0 ?? у меня не работает :(
ronim писал(а):
10.01.2020 20:30
tyson, Отвечу цитатами
ronim писал(а):
08.01.2020 12:51
sky_diver, То же была ошибка с расширением Татьяны.Проблему решил так : отключил ,удалил данные, потом перезалил версию с гитнаба( с летним фиксом).После этого встало без проблем.
sky_diver писал(а):
08.01.2020 12:59
ronim, проделал как Вы описали - расширение Татьяны заработало. Спасибо!

попробуйте
Если ты не видишь проблем на форуме , но это не значить что их там нет

Аватара пользователя
RUFOND
phpBB 1.4.4
Сообщения: 122
Зарегистрирован: 25.01.2007 1:21
Откуда: Москва
Благодарил (а): 2 раза
Поблагодарили: 2 раза

Re: [3.3] Несовместимые расширения

Сообщение RUFOND »

KEMnEP писал(а):
17.01.2020 14:30
QuickReply Reloaded - выдаёт ошибку
Странно, возможно в своё время уже была установлена правленная версия. Но у меня работает без проблем на 3.3
//
приглашаю на RuFOND - Форум для трейдеров

Аватара пользователя
KEMnEP
phpBB 2.0.11
Сообщения: 833
Зарегистрирован: 22.03.2015 16:32
Благодарил (а): 35 раз
Поблагодарили: 202 раза

Re: [3.3] Несовместимые расширения

Сообщение KEMnEP »

RUFOND, цитируйте правильно
не
RUFOND писал(а):
18.01.2020 12:15
QuickReply Reloaded - выдаёт ошибку
а
KEMnEP писал(а):
17.01.2020 14:30
QuickReply Reloaded - по словам автора пока не совместим.
ибо
Татьяна5 писал(а):
07.01.2020 17:33
Запустится, но по мелочи будут баги пока что

Аватара пользователя
LavIgor
Поддержка
Поддержка
Сообщения: 3459
Зарегистрирован: 28.04.2014 8:16
Благодарил (а): 39 раз
Поблагодарили: 927 раз

Re: [3.3] Несовместимые расширения

Сообщение LavIgor »

ronim писал(а):
18.01.2020 3:27
это что про меня?
Имелись в виду те люди, которые на официальном англоязычном форуме ответили, что версия с GitHub у них работает на 3.3.

agrash
phpBB 1.0.0
Сообщения: 7
Зарегистрирован: 01.11.2010 1:00
Благодарил (а): 6 раз
Поблагодарили: 1 раз

Re: [3.3] Несовместимые расширения

Сообщение agrash »

Расширения Copyright in footer и Pagescroller не работают после обновления до версии phpbb 3.3.

При их включении возникает ошибка:
Произошла ошибка phpBB при компиляции контейнера, связанная с одним из установленных расширений. По этой причине, все установленные расширения были временно отключены. Попробуйте очистить кэш конференции. Все расширения будут автоматически включены, если ошибка контейнера будет устранена. В противном случае, обратитесь на сайт официальной русской поддержки phpBB Guru для получения помощи.
Кэш конференции чистил, не помогает.
Если Pagescroller пока официально не поддерживает phpbb 3.3, то Copyright in footer - должен поддерживать. Но на самом деле, оба разрешения сейчас не совместимы с phpbb 3.3.

Если можно исправить,чтобы работало, подскажите, пожалуйста, что и как сделать (пошагово). Заранее спасибо!

Аватара пользователя
COB16
phpBB 2.0.15
Сообщения: 1002
Зарегистрирован: 05.10.2014 21:08
Откуда: Беларусь
Благодарил (а): 314 раз
Поблагодарили: 58 раз

Re: [3.3] Несовместимые расширения

Сообщение COB16 »

agrash, services.yml кавычки нужно поставить
Вот правильный вид для Pagescroller

Код: Выделить всё

services:
    darkdiesel.pagescroller.listener:
        class: darkdiesel\pagescroller\event\main_listener
        arguments:
            - '@config'
            - '@ext.manager'
            - '@template'
            - '%core.root_path%'
        tags:
            - { name: event.listener }
Отправлено спустя 9 минут 41 секунду:
аналогично и для второго,заменить на этот текст

Код: Выделить всё

services:
    dmzx.copyright.listener:
        class: dmzx\copyright\event\listener
        arguments:
            - '@config'
            - '@template'
        tags:
            - { name: event.listener }

agrash
phpBB 1.0.0
Сообщения: 7
Зарегистрирован: 01.11.2010 1:00
Благодарил (а): 6 раз
Поблагодарили: 1 раз

Re: [3.3] Несовместимые расширения

Сообщение agrash »

COB16, спасибо большое!

Уточняю для других: services.yml находится внутри папки config соответствующего расширения:

Изображение

С Pagescroller у меня сразу всё получилось.

А в коде Copyright in footer была пропущена строчка - '@user', без которой всё сыпалось.
Ниже - правильный код:

Код: Выделить всё

services:
    dmzx.copyright.listener:
        class: dmzx\copyright\event\listener
        arguments:
            - '@config'
            - '@template'
            - '@user'
        tags:
            - { name: event.listener }

TrekRed
phpBB 2.0.2
Сообщения: 329
Зарегистрирован: 09.08.2018 1:11
Благодарил (а): 48 раз
Поблагодарили: 11 раз

Re: Вышел phpBB 3.3.0 [обсуждаем]

Сообщение TrekRed »

Наконец-то обновился 3.3 и перешел на php 7.3, все работает кроме 3 расширений: Contact Admin, Profile side switcher и слайдера картинок. Подскажите решение данных расширений. Все изменения внесены!

Аватара пользователя
Webliberty
phpBB 2.0.4
Сообщения: 427
Зарегистрирован: 22.12.2011 11:03
Благодарил (а): 155 раз
Поблагодарили: 59 раз

Re: Вышел phpBB 3.3.0 [обсуждаем]

Сообщение Webliberty »

Ну вообще странно все, вроде phpBB 3.3.0 мало отличается от той же 3.2.9, только внешние библиотеки обновили, да поддержка PHP 7.3 и выше появилась, по идее должны расширения работать. А если и не работают, то исправить их не долго. Видимо авторы расширений загружены работой, у всех же есть работа, семья.

Я вот не обновляюсь пока, т.к. знаю что одно или несколько расширений точно не будет работать стабильно на новой версии.
TrekRed писал(а):
25.01.2020 15:46
все работает кроме 3 расширений: Contact Admin, Profile side switcher и слайдера картинок
Попробуйте поискать замену этим расширениям, с теми же функциями, которые будут работать.

Или хорошенько подумать: а нужны ли они вообще? :D
Мой форум на phpBB 3.2.9 (начинал с phpBB 3.0.9)
Подпись заверена нотариусом :P

TrekRed
phpBB 2.0.2
Сообщения: 329
Зарегистрирован: 09.08.2018 1:11
Благодарил (а): 48 раз
Поблагодарили: 11 раз

Re: Вышел phpBB 3.3.0 [обсуждаем]

Сообщение TrekRed »

Все указанные выше проблемы решил, все работает. Но есть еще одно проблемное расширение конкурса activeuser-master. При открытии ошибка: "Looks like you try to load a template outside configured directories (../theme/activeuser.css) in "activeuser_body.html" at line 1." Это единственное расширение, которое на данный момент не работает с 3.3. Может кто знает решение и смысл этой ошибки?

Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 14744
Зарегистрирован: 12.05.2006 18:16
Откуда: Красноярск
Благодарил (а): 354 раза
Поблагодарили: 1623 раза

Re: Вышел phpBB 3.3.0 [обсуждаем]

Сообщение rxu »

TrekRed писал(а):
25.01.2020 19:27
расширение конкурса activeuser-master
Как только догадаемся, что это и где его искать, так сразу начнем разбираться.
Изображение

Вернуться в «Поддержка phpBB 3.3.x»